HDU 6186 前缀后缀

题目

CS Course

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 595    Accepted Submission(s): 290


Problem Description
Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers  a1,a2,,an , and some queries.

A query only contains a positive integer p, which means you 
are asked to answer the result of bit-operations (and, or, xor) of all the integers except  ap .
 

Input
There are no more than 15 test cases. 

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2n,q105

Then n non-negative integers  a1,a2,,an  follows in a line,  0ai109  for each i in range[1,n].

After that there are q positive integers  p1,p2,,pq in q lines,  1pin  for each i in range[1,q].
 

Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except  ap  in a line.
 

Sample Input
  
  
3 3 1 1 1 1 2 3
 

Sample Output
  
  
1 1 0 1 1 0 1 1 0
 

Source
 

题意
  很好懂,不解释了

解题思路
 一个数异或本身等于0,0异或任何数都没有影响,所以异或操作只需要预处理一下所有数的异或结果,最后异或一下这个数本身就是所求啦
 逻辑且和逻辑或存一下前缀和后缀最后做一个运算就可以了
 这里要注意一下逻辑且的预处理我这里预处理成   2的30次幂减一 ,数据范围是1e9 ,也就是三个2的10次幂,大体估算了一下,应该不是很准确,但一定是大于等于的

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std ;
const int maxn = 100000 + 10 ;
int a[maxn] ;
int an[maxn] , lan[maxn] , o[maxn] , lo[maxn] ;
int main()
{
    int n , m ;
    while(scanf("%d %d" , &n , &m) != EOF)
    {
        int xo = 0 ;
        memset(o , 0 , sizeof(o)) ;
        memset(lo , 0 , sizeof(lo)) ;
        for(int i = 1 ; i <= n ; i++)
        {
            scanf("%d" , &a[i]);
            xo ^= a[i] ;
            an[i] = (1 << 30) - 1 , lan[i] = (1 << 30) - 1 ;
        }
        an[0] = (1 << 30) - 1 , lan[n+1] = (1 << 30) - 1 ;
        for(int i = 1 , j = n ; i <= n && j >= 1 ; i++ , j--)
        {
            an[i] = an[i-1] & a[i] ;
            o[i] = o[i-1] | a[i] ;
            lan[j] = lan[j+1] & a[j] ;
            lo[j] = lo[j+1] | a[j] ;
        }
        for(int i = 0 ; i < m ; i++)
        {
            int q ;
            scanf("%d" , &q) ;
            printf("%d %d %d\n" , an[q-1] & lan[q+1] , o[q-1] | lo[q+1] , xo ^ a[q]) ;
        }
    }
    return 0 ;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值