题目
A children’s puzzle that was popular 30 years ago consisted of a 5×5 frame which contained 24 smallsquares of equal size. A unique letter of the alphabet was printed on each small square. Since therewere only 24 squares within
the frame, the frame also contained an empty position which was the samesize as a small square. A square could be moved into that empty position if it were immediately to theright, to the left, above, or below the empty position. The object of the puzzle was
to slide squaresinto the empty position so that the frame displayed the letters in alphabetical order.
The illustration below represents a puzzle in its original configuration and in its configuration afterthe following sequence of 6 moves:
1) The square above the empty position moves.
2) The square to the right of the empty position moves.
3) The square to the right of the empty position moves.
4) The square below the empty position moves.
5) The square below the empty position moves.
6) The square to the left of the empty position moves.
Write a program to display resulting frames given their initial configurations and sequences of moves.
Input
Input for your program consists of several puzzles. Each is described by its initial configuration andthe sequence of moves on the puzzle. The first 5 lines of each puzzle description are the startingconfiguration. Subsequent
lines give the sequence of moves.
The first line of the frame display corresponds to the top line of squares in the puzzle. The otherlines follow in order. The empty position in a frame is indicated by a blank. Each display line containsexactly 5 characters,
beginning with the character on the leftmost square (or a blank if the leftmostsquare is actually the empty frame position). The display lines will correspond to a legitimate puzzle.
The sequence of moves is represented by a sequence of As, Bs, Rs, and Ls to denote which squaremoves into the empty position. A denotes that the square above the empty position moves; B denotesthat the square below the empty
position moves; L denotes that the square to the left of the emptyposition moves; R denotes that the square to the right of the empty position moves. It is possible thatthere is an illegal move, even when it is represented by one of the 4 move characters.
If an illegal moveoccurs, the puzzle is considered to have no final configuration. This sequence of moves may be spreadover several lines, but it always ends in the digit 0. The end of data is denoted by the character Z.
Output
Output for each puzzle begins with an appropriately labeled number (Puzzle #1, Puzzle #2, etc.). Ifthe puzzle has no final configuration, then a message to that effect should follow. Otherwise that finalconfiguration should be
displayed.
Format each line for a final configuration so that there is a single blank character between twoadjacent letters. Treat the empty square the same as a letter. For example, if the blank is an interiorposition, then it will appear
as a sequence of 3 blanks — one to separate it from the square to the left,one for the empty position itself, and one to separate it from the square to the right.
Separate output from different puzzle records by one blank line.
Note: The first record of the sample input corresponds to the puzzle illustrated above
Sample Input
Sample Output
题目大意
类似一个拼图,不断按照命令移动,最终输出。
代码
题意很简单也好理解,代码也比较容易
#include <iostream>
#include <cstdio>
using namespace std;
int main()
{
char a[5][7];
char cmd[1005];
int kase=0;
while(gets(a[0])) //首先输入第一行
{
if(a[0][0]=='Z') break; //如果是Z 退出程序
for(int i=1;i<5;i++) gets(a[i]);
int xx=0,yy=0;
for(int i=0;i<5;i++)
{
for(int j=0;j<5;j++)
if(a[i][j]==' ')
{
xx=i,yy=j;
i=j=5; //直接跳出双重循环
}
}
int k=0;
while((cmd[k++]=getchar()) != '0'); //输入命令,命令终止条件是最后一个是0
getchar();//后来将所有指令读入后,还是有一个回车载缓冲区中,
//因此需要使用getchar函数读出这个字符,从而保证缓冲区是空的;
int flag=0,x=xx,y=yy;
for(int i=0;i<k;i++)
{
if(cmd[i]=='A')
x=xx-1,y=yy;
else if(cmd[i]=='B')
x=xx+1,y=yy;
else if(cmd[i]=='L')
x=xx,y=yy-1;
else if(cmd[i]=='R')
x=xx,y=yy+1;
if(x<0||x>4||y<0||y>4)
{
flag=1;
break;
} //操作越界 flag标记一下
else
{
a[xx][yy]=a[x][y];
a[x][y]=' ';
xx=x,yy=y; //空格位置发生改变
}
}
if(kase++)
cout<<endl; //根据题意首先输出一个空行
cout<<"Puzzle #"<<kase<<":"<<endl;
if(flag)
cout<<"This puzzle has no final configuration."<<endl; //flag事先标记,如果操作越界,输出文字
else
{
for(int i=0;i<5;i++)
{
for(int j=0;j<5; j++)
{
if(j!=0) cout<<" ";
cout<<a[i][j];
}
cout<<endl;;
}
}
}
return 0;
}
注意
25行