Pie _HDU1969

题目

 

My birthday is coming up and traditionally I'm serving pie. Not just one pie, no, I have a number N of them, of various tastes and of various sizes. F of my friends are coming to my party and each of them gets a piece of pie. This should be one piece of one pie, not several small pieces since that looks messy. This piece can be one whole pie though.

My friends are very annoying and if one of them gets a bigger piece than the others, they start complaining. Therefore all of them should get equally sized (but not necessarily equally shaped) pieces, even if this leads to some pie getting spoiled (which is better than spoiling the party). Of course, I want a piece of pie for myself too, and that piece should also be of the same size.

What is the largest possible piece size all of us can get? All the pies are cylindrical in shape and they all have the same height 1, but the radii of the pies can be different.

Input

One line with a positive integer: the number of test cases. Then for each test case:
---One line with two integers N and F with 1 <= N, F <= 10 000: the number of pies and the number of friends.
---One line with N integers ri with 1 <= ri <= 10 000: the radii of the pies.

Output

For each test case, output one line with the largest possible volume V such that me and my friends can all get a pie piece of size V. The answer should be given as a floating point number with an absolute error of at most 10^(-3).

Sample Input

3
3 3
4 3 3
1 24
5
10 5
1 4 2 3 4 5 6 5 4 2

Sample Output

25.1327
3.1416
50.2655

题目大意 

 n个派,f+1个人。

f+1个人均分n个派

要求每个人获得的派必须是完整的,不能使拼接起来的。

采用二分来猜测每个人获得的派的大小

 

相对来说比较简单,需要注意以下几点

1 pi的大小精度要设置好 pi=acos(-1.0);

2 我一开始是设置high为所有半径和均分,这样得到的结果与题目给出的样例不符合,可能是精度不够,后来改成体积之和就ok了

3 有一个点要想到  一张派可以切成好几份,这样照样可能是最大值 也就是

for(int j=0;j<n;j++) cnt+=int(r[j]/mid);

4 题目中的f是好友数量,要加上自己,一共f+1个人均分派

代码

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
using namespace std;
double r[10010],pi=acos(-1.0);
int main()
{
	int t,n,f;
	cin>>t;
	while(t--)
	{
		cin>>n>>f;
		f++;
		double sum=0;
		for(int i=0;i<n;i++) {cin>>r[i]; r[i]=r[i]*r[i]*pi; sum+=r[i];}
		double low=0,high=sum/f,mid;
		while(high>low+1e-6)
		{
			int cnt=0;
			mid=(low+high)/2;
			for(int j=0;j<n;j++) cnt+=int(r[j]/mid);
			if(cnt>=f) low=mid;
			else high=mid;
		}
		printf("%.4lf\n",mid);
	}
	
	return 0;
}


 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Cherish_lii

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值