HDU ACM1050——Moving Tables

41 篇文章 0 订阅
34 篇文章 0 订阅

Moving Tables

Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure.
在这里插入图片描述
The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving.

在这里插入图片描述

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output

The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3
4
10 20
30 40
50 60
70 80
2
1 3
2 200
3
10 100
20 80
30 50

Sample Output

10
20
30

题解:搬桌子会占用两个房间之间的过道,如果占用的过道不重合则可以同时搬桌子(算一轮),求如何将过道充分利用使搬桌子的轮次最少。

看到这个题目的第一想法是死做,即建一个结构体(两个房间号),小的放左边(l),以l排序,然后一遍遍找能最大化将过道填充的搬运房间,即确定了第一个左房间,然后从右房间开始找第二个左房间。代码如下:

#include<stdio.h>
#include<algorithm>
using namespace std;
#define maxn 101

struct room{
    int l;
    int r;
}Move[201];	/*两个移动房间的房间号*/
 
bool cmp(room al,room bl){
    return al.l<bl.l;
}

int main()
{
    int T,n,i;
    while(scanf("%d",&T)!=EOF){
        while(T--){
            scanf("%d",&n);
            for(i=0;i<n;i++){
                scanf("%d %d",&Move[i].l,&Move[i].r);
                if(Move[i].l>Move[i].r){	/*把较小的房间号放左边,方便排序*/ 
                    int t=Move[i].l;
                    Move[i].l=Move[i].r;
                    Move[i].r=t;
                }
                Move[i].l=(Move[i].l+1)/2;	/*由于两个房间公用一条过道,所以除以二*/ 
				Move[i].r=(Move[i].r+1)/2; 
            }
            sort(Move,Move+n,cmp);
            int num,cnt,flag;	/*num表示最少要几轮次才能搬完*/ 
            cnt=num=0;
            while(cnt<n){
                flag=-1;	/*flag=-1即新的一轮开始*/ 
                for(i=0;i<n;i++){
                    if(Move[i].l>flag){
                        cnt++;	/*cnt计算总共搬桌子的次数*/ 
                        if(flag<0)num++;
                        flag=Move[i].r;
                        Move[i].l=-1;
                    }
                }
            }
            printf("%d\n",num*10);
        }
    }
    return 0;
 } 

但是后来发现这个方法太复杂,找到了一种更简单的方法,其思路是将每次搬运桌子两个房间之间的过道都标记一次,表示走过了一次,最后找出过道内走过次数最多的那个点,就是最少搬运次数。代码如下:

#include<stdio.h>
#include<string.h>
int main()
{
	int T,n,i,j,l,r,passed[201];	
	while(scanf("%d",&T)!=EOF){
		while(T--){
			scanf("%d",&n);
			memset(passed,0,sizeof(passed));
			for(i=0;i<n;i++){
				scanf("%d %d",&l,&r);
				if(l>r){
					int t=l;l=r;r=t;
				}
				for(j=(l+1)/2;j<=(r+1)/2;j++)
					passed[j]++;	/*本轮次搬运桌子所有经过的过道点标记一次*/
			}
			
			int cnt=-1;
			for(i=0;i<201;i++)	/*找出被标记次数最多的过道点,就是最少搬运次数*/ 
				if(passed[i]>cnt)cnt=passed[i];
			printf("%d\n",cnt*10);
		}
	}
	return 0;
 } 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值