HDU 2845 Beans(dp:二维转换的最大不连续子序列和)

本文介绍了一种解决HDU 2845 Beans问题的方法,通过二维动态规划来找到最大不连续子序列和。
摘要由CSDN通过智能技术生成

Beans

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5572    Accepted Submission(s): 2527


Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.


Now, how much qualities can you eat and then get ?
 

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.
 

Output
For each case, you just output the MAX qualities you can eat and then get.
 

Sample Input
 
 
4 6
11 0 7 5 13 9
78 4 81 6 22 4
1 40 9 34 16 10
11 22 0 33 39 6
 
Sample Output
 
 
242

这道题的思路是先求单独一行的最大不连续子序列,然后在把每一行的最大不连续子序列和看成一个元素,进而再求所有行最大不连续子序列和。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dpx[200005];//dpx[i]:当前这一行的前i列的最大不连续子序列和 
int dpy[200005];//dpy[i]:前i行的最大不连续子序列和,名称dpy,不太准确 
int main()
{
	int n,m;
	while(~scanf("%d%d",&n,&m))
	{
		int num;
		memset(dpx,0,sizeof(dpx));
		memset(dpy,0,sizeof(dpy));
		for(int i=2;i<=n+1;i++)
		{
			for(int j=2;j<=m+1;j++)
			{
				scanf("%d",&num);
				//当前(i,j)有两个状态;不选则(i,j-1),选则(i,j-2)+(i,j); 
				dpx[j]=max(dpx[j-1],dpx[j-2]+num);
			}
			//求整体,对每一行也是都有两个状态,要么整行不选,要么选
			//选的话加上当前整行的最大不连续子序列和dpx[m+1]
			dpy[i]=max(dpy[i-1],dpy[i-2]+dpx[m+1]); 
		}
		printf("%d\n",dpy[n+1]);
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值