HDU 2830 Matrix Swapping II(最大完全子矩阵)

Matrix Swapping II

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2201    Accepted Submission(s): 1475

Problem Description
Given an N * M matrix with each entry equal to 0 or 1. We can find some rectangles in the matrix whose entries are all 1, and we define the maximum area of such rectangle as this matrix’s goodness. 

We can swap any two columns any times, and we are to make the goodness of the matrix as large as possible.  

Input
There are several test cases in the input. The first line of each test case contains two integers N and M (1 ≤ N,M ≤ 1000). Then N lines follow, each contains M numbers (0 or 1), indicating the N * M matrix
 
Output
Output one line for each test case, indicating the maximum possible goodness.
 
Sample Input
 
 
3 4
1011
1001
0001
3 4
1010
1001
0001
 
Sample Output
 
 
4
2


h [ j ]是当前行的第j列点为底的高度,每次sort,高度从大到小排,第一个高度最大,所以宽度只能是1,第二个宽度所以能延伸到2。,类似HDU 1506,1505

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int maxn = 1005;
char mp[maxn][maxn];
int h[maxn];
int hh[maxn];
bool cmp(int a,int b)
{
	return a>b;
}
int main()
{
     int n,m;
	 while(scanf("%d%d",&n,&m)!=EOF)
	 {
		int ans = 0;
		getchar();
		memset(h,0,sizeof(h));
		for(int i = 1;i<=n;i++)
		{
			for(int j = 1;j<=m;j++)
			{
			    scanf("%c",&mp[i][j]);
				if(mp[i][j]=='1')
					h[j]++;
				 else
					h[j]=0;
				hh[j]=h[j];
			}
			sort(hh+1,hh+1+m,cmp);
			for (int j = 1;j<=m;j++)
			{//hh[j]是高度,j是宽度
				ans = max(ans,hh[j]*j);
			}
			getchar();
		}
		printf("%d\n",ans);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值