poj 3349 哈希

SnowflakeSnowSnowflakes
Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 35040 Accepted: 9214

Description

You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.

Input

The first line of input will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed byn lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.

Output

If all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.

Sample Input

2
1 2 3 4 5 6
4 3 2 1 6 5

Sample Output

Twin snowflakes found.

Source

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define temp 999983

using namespace std;

struct node
{
    int num[6];
    node *next;
}*head[1000000];
int Creat(int a[])
{
    int key=0;
    for(int i=0; i<6; i++)
    {
        key+=a[i]%temp;
        key %=temp;
    }
    return ++key;  //让从1开始
}
int panduan(node *p,int a[])
{
    int biao;
    for(int i=0; i<6; i++) //顺时针
    {
        biao=1;
        for(int j=0; j<6; j++)
        {
            if(a[j]!=p->num[(i+j)%6])
            {
                biao=0;
                break;
            }
        }
        if(biao)
            return 1;
    }
    for(int i=0; i<6; i++) //逆时针
    {
        biao=1;
        for(int j=0; j<6; j++)
        {
            if(a[j]!=p->num[(5-i-j+6)%6])
            {
                biao=0;
                break;
            }
        }
        if(biao)
            return 1;
    }
    return 0;
}
int Build(int key,int a[])
{
    if(!head[key])
    {
        node *p;
        p=new node;
        p->next=NULL;         //必须有,否则RE..以后链表题一定要写->next=NULL
                                              //p->next 有自己的地址的
        for(int i=0; i<6; i++)
            p->num[i]=a[i];
        head[key]=p;
    }
    else
    {
        node *p=head[key];
        int k=1;
        while(p)
        {
            if(panduan(p,a))
            {
                return 1;
            }
            p=p->next;
        }
        p=new node;                           //此处不能直接给空指针p直接赋值,需要先开辟新内存 <span id="transmark"></span> 决定p指向类型
        p->next=NULL;
        for(int i=0; i<6; i++)
            p->num[i]=a[i];
    }
    return 0;
}
int main()
{
    int n;
    int a[10];
    while(~scanf("%d",&n))
    {
        int flag=0;
        memset(head,0,sizeof(head));
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<6; j++)
            {
                scanf("%d",&a[j]);
            }
            if(flag==0)
            {
                int key=Creat(a);
                flag=Build(key,a);
            }
        }
        if(flag)
            printf("Twin snowflakes found.\n");
        else
            printf("No two snowflakes are alike.\n");
    }
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值