HDU 5477A Sweet Journey网赛

A Sweet Journey

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 175    Accepted Submission(s): 87


Problem Description
Master Di plans to take his girlfriend for a travel by bike. Their journey, which can be seen as a line segment of length L, is a road of swamps and flats. In the swamp, it takes A point strengths per meter for Master Di to ride; In the flats, Master Di will regain B point strengths per meter when riding. Master Di wonders:In the beginning, he needs to prepare how much minimum strengths. (Except riding all the time,Master Di has no other choice)

 

Input
In the first line there is an integer t ( 1t50 ), indicating the number of test cases.
For each test case:
The first line contains four integers, n, A, B, L.
Next n lines, each line contains two integers: Li,Ri , which represents the interval [Li,Ri] is swamp.
1n100,1L105,1A10,1B101Li<RiL .
Make sure intervals are not overlapped which means Ri<Li+1 for each i ( 1i<n ).
Others are all flats except the swamps.
 

Output
For each text case:
Please output “Case #k: answer”(without quotes) one line, where k means the case number counting from 1, and the answer is his minimum strengths in the beginning.
 

Sample Input
  
  
1 2 2 2 5 1 2 3 4
 

Sample Output
  
  
Case #1: 0
 
题意是,在一个L长的道路上 存在减少能量的的地方存在, 剩余地方都是增加能量的地方
问初始的能量应该为多少,才能使人安全通过.
即在行驶过程中不能使能量和为负数了

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:   5478  5476  5475  5474  5473
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#define INF 0x3f3f3f3f

using namespace std;

int vis[600000];
int main()
{
	int T,n,A,B,L,a,b;
	while(~scanf("%d",&T))
	{
		int Case=0;
		while(T--)
		{
			Case++;
			scanf("%d%d%d%d",&n,&A,&B,&L);
			for(int i=0;i<L;i++)
			  vis[i]=B;
			for(int i=0;i<n;i++)
			{
				scanf("%d%d",&a,&b);
				for(int j=a;j<b;j++)
					vis[j]=-A;
			}
			long long sum=0,Min=0;
          //int sum=0;
			for(int i=0;i<=L;i++)
			{
				sum+=vis[i];
//				cout<<sum;
//				cout<<sum;
				if(sum<Min)
					Min=sum;
			}
           //cout<<Min;
           printf("Case #%d: ",Case);
		    printf("%lld\n",0-Min);
		}
	}
}


 

S
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值