Power Network--最大流的EK()算法

Power Network
Time Limit: 2000MS Memory Limit: 32768K
Total Submissions: 27108 Accepted: 14083

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= p max(u) of power, may consume an amount 0 <= c(u) <= min(s(u),c max(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= l max(u,v) of power delivered by u to v. Let Con=Σ uc(u) be the power consumed in the net. The problem is to compute the maximum value of Con. 

An example is in figure 1. The label x/y of power station u shows that p(u)=x and p max(u)=y. The label x/y of consumer u shows that c(u)=x and c max(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and l max(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6. 

Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of l max(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of p max(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of c max(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.

Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.

Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
         (3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
         (0)5 (1)2 (3)2 (4)1 (5)4

Sample Output

15
6

Hint

The sample input contains two data sets. The first data set encodes a network with 2 nodes, power station 0 with pmax(0)=15 and consumer 1 with cmax(1)=20, and 2 power transport lines with lmax(0,1)=20 and lmax(1,0)=10. The maximum value of Con is 15. The second data set encodes the network from figure 1.

题目链接:http://poj.org/problem?id=1459


看网络流一天了,发现难点并不是在网络流上,而是在怎么去建图上,或者说怎么去找一个超级源点和超级汇点上,这个比二分图还难建图。


题目大意是有n个点,其中有nc个点是发电站,有np个点是用户,其他的是中转站,求最大流


解题思路也没有什么,虚拟一个超级源点,一个超级汇点,就是一个裸地板子题,我自己敲了一发,超时了,还是老老实实的用大神的板子吧。

一定要注意这个题的输入,我卡了一个小时在输入上。

代码:

#include <iostream>
#include <cstring>
#include <queue>
#include <cstdio>
#define inf 0x3f3f3f3f
using namespace std;
int map1[1000][1000],pre[1000],vis[1000],n;
int EK()
{
    int i,ans=0,now,min1;
    queue <int> q;
    while(1)//每次循环找一次增广路
    {
        memset(pre,-1,sizeof(pre));
        memset(vis,0,sizeof(vis));
        while(!q.empty())
        {
            q.pop();
        }
        q.push(0);
        vis[0]=1;
        while(!q.empty())
        {
            now=q.front();
            q.pop();
            if(now==n+1)//找到超级汇点
            {
                break;
            }
            for(i=0;i<=n+1;i++)//板子,残量网络
            {
                if(!vis[i]&&map1[now][i]>0)
                {
                    pre[i]=now;
                    vis[i]=1;
                    q.push(i);
                }
            }
        }
        if(!vis[n+1])//如果bfs没有搜索到超级汇点,跳出循环
        {
            break;
        }
        min1=inf;
        for(i=n+1;i!=0;i=pre[i])
        {
            if(map1[pre[i]][i]<min1)
            {
                min1=map1[pre[i]][i];
            }
        }
        ans+=min1;
        for(i=n+1;i!=0;i=pre[i])
        {
            map1[pre[i]][i]-=min1;
            map1[i][pre[i]]+=min1;
        }
    }
    return ans;
}
int main()
{
    int np,nc,m,i;
    while(cin >> n >> np >> nc >> m)
    {
        char ch;
        int u,v,w;
        memset(map1,0,sizeof(map1));
        for(i=0;i<m;i++)
        {
            cin >>ch>> u >>ch>> v >>ch>> w;//输入是真的坑
            if(u!=v)
            {
                map1[u+1][v+1]=w;
            }
        }
        for(i=0;i<np;i++)
        {
            cin >>ch>> v >>ch>> w ;
            map1[0][v+1]=w;
        }
        for(i=0;i<nc;i++)
        {
            cin >> ch >> u >> ch>> w ;
            map1[u+1][n+1]=w;
        }
       cout << EK() << endl;
    }
    return 0;
}

贴上几个我学网络流时看的几个主要的博客吧。

网络流EK入门,讲的很详细

http://www.cnblogs.com/zsboy/archive/2013/01/27/2878810.html

残量网络及一些其他的东西,讲的挺好

http://www.cnblogs.com/luweiseu/archive/2012/07/14/2591573.html


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值