Ball--智商题

Ball

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 189    Accepted Submission(s): 113


Problem Description
ZZX has a sequence of boxes numbered  1,2,...,n . Each box can contain at most one ball.

You are given the initial configuration of the balls. For  1in , if the  i -th box is empty then  a[i]=0 , otherwise the i-th box contains exactly one ball, the color of which is a[i], a positive integer. Balls with the same color cannot be distinguished.

He will perform m operations in order. At the i-th operation, he collects all the balls from boxes l[i],l[i]+1,...,r[i]-1,r[i], and then arbitrarily put them back to these boxes. (Note that each box should always contain at most one ball)

He wants to change the configuration of the balls from a[1..n] to b[1..n] (given in the same format as a[1..n]), using these operations. Please tell him whether it is possible to achieve his goal.
 

Input
First line contains an integer t. Then t testcases follow. 
In each testcase: First line contains two integers n and m. Second line contains a[1],a[2],...,a[n]. Third line contains b[1],b[2],...,b[n]. Each of the next m lines contains two integers l[i],r[i].

1<=n<=1000,0<=m<=1000, sum of n over all testcases <=2000, sum of m over all testcases <=2000.

0<=a[i],b[i]<=n.

1<=l[i]<=r[i]<=n.
 

Output
For each testcase, print "Yes" or "No" in a line.
 

Sample Input
  
  
5 4 1 0 0 1 1 0 1 1 1 1 4 4 1 0 0 1 1 0 0 2 2 1 4 4 2 1 0 0 0 0 0 0 1 1 3 3 4 4 2 1 0 0 0 0 0 0 1 3 4 1 3 5 2 1 1 2 2 0 2 2 1 1 0 1 3 2 4
 

Sample Output
  
  
No No Yes No Yes
 

Author
学军中学
 

Source
 

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5821


这一场多校打的我迷之心累啊。


这个题的意思是说有A,B两个序列,每次从把A的l,r区间的数全部取出,然后任意放入,问经过m次操作后A,是否能够和B状态一样,每个盒子至多一个放球,数字可理解为球的状态。


先预处理,把A里面的球在B种找到相应的位置,然后改变这些位置,最后看能否形成1,2,3,4.。。。n这样的序列。

TAT


代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
int a[10000];//A
int b[10000];//B
int c[20000];//标记数组
int d[10000];//记录数组
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int i,j;
        int n,m,left,right;
        memset(d,0,sizeof(d));
        memset(c,0,sizeof(c));
        scanf("%d%d",&n,&m);
        for(i=1;i<=n;i++)
            scanf("%d",&a[i]);
        for(i=1;i<=n;i++)
            scanf("%d",&b[i]);
        for(i=1;i<=n;i++)
        {
            for(j=1;j<=n;j++)
            {
                if(a[i]==b[j]&&!c[j])
                {
                    c[j]=1;
                    d[i]=j;
                    break;
                }
            }
            if(j==n+1)
                break;
        }
        while(m--)
        {
            scanf("%d%d",&left,&right);
            sort(d+left,d+right+1);
        }
        if(i!=n+1)
        {
            cout<<"No"<<endl;
            continue;
        }
        int sum=0;
        for(i=1;i<=n;i++)
        {
            if(d[i]!=i)
                break;
        }
        if(i==n+1)
            cout<<"Yes"<<endl;
        else
            cout<<"No"<<endl;
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值