Circle and Points----单位圆覆盖最多点

Circle and Points
Time Limit: 5000MS Memory Limit: 30000K
Total Submissions: 7941 Accepted: 2852
Case Time Limit: 2000MS

Description

You are given N points in the xy-plane. You have a circle of radius one and move it on the xy-plane, so as to enclose as many of the points as possible. Find how many points can be simultaneously enclosed at the maximum. A point is considered enclosed by a circle when it is inside or on the circle. 
 
Fig 1. Circle and Points

Input

The input consists of a series of data sets, followed by a single line only containing a single character '0', which indicates the end of the input. Each data set begins with a line containing an integer N, which indicates the number of points in the data set. It is followed by N lines describing the coordinates of the points. Each of the N lines has two decimal fractions X and Y, describing the x- and y-coordinates of a point, respectively. They are given with five digits after the decimal point. 

You may assume 1 <= N <= 300, 0.0 <= X <= 10.0, and 0.0 <= Y <= 10.0. No two points are closer than 0.0001. No two points in a data set are approximately at a distance of 2.0. More precisely, for any two points in a data set, the distance d between the two never satisfies 1.9999 <= d <= 2.0001. Finally, no three points in a data set are simultaneously very close to a single circle of radius one. More precisely, let P1, P2, and P3 be any three points in a data set, and d1, d2, and d3 the distances from an arbitrarily selected point in the xy-plane to each of them respectively. Then it never simultaneously holds that 0.9999 <= di <= 1.0001 (i = 1, 2, 3). 

Output

For each data set, print a single line containing the maximum number of points in the data set that can be simultaneously enclosed by a circle of radius one. No other characters including leading and trailing spaces should be printed.

Sample Input

3
6.47634 7.69628
5.16828 4.79915
6.69533 6.20378
6
7.15296 4.08328
6.50827 2.69466
5.91219 3.86661
5.29853 4.16097
6.10838 3.46039
6.34060 2.41599
8
7.90650 4.01746
4.10998 4.18354
4.67289 4.01887
6.33885 4.28388
4.98106 3.82728
5.12379 5.16473
7.84664 4.67693
4.02776 3.87990
20
6.65128 5.47490
6.42743 6.26189
6.35864 4.61611
6.59020 4.54228
4.43967 5.70059
4.38226 5.70536
5.50755 6.18163
7.41971 6.13668
6.71936 3.04496
5.61832 4.23857
5.99424 4.29328
5.60961 4.32998
6.82242 5.79683
5.44693 3.82724
6.70906 3.65736
7.89087 5.68000
6.23300 4.59530
5.92401 4.92329
6.24168 3.81389
6.22671 3.62210
0

Sample Output

2
5
5
11
题目链接:http://poj.org/problem?id=1981


比赛的时候没有带板子,柴爷板子上的原题。

题目的意思是说给定一个单位圆,求最多覆盖多少点,这个计算几何题我还真不会。。。只能上柴爷的板子了。

代码:

#include <cstdio>
#include <cstring>
#include <iostream>
#include <cmath>
#define eps 1e-6
using namespace std;
struct point{
    double x,y;
};
double dis(point p1,point p2){
    point p3;
    p3.x=p2.x-p1.x;
    p3.y=p2.y-p1.y;
    return p3.x*p3.x+p3.y*p3.y;
}
point find_centre(point p1,point p2){
    point p3,mid,centre;
    double b,c,ang;
    p3.x=p2.x-p1.x;
    p3.y=p2.y-p1.y;
    mid.x=(p1.x+p2.x)/2;
    mid.y=(p1.y+p2.y)/2;
    b=dis(p1,mid);
    c=sqrt(1-b);
    if(fabs(p3.y)<eps){//垂直的斜角90度
        centre.x=mid.x;
        centre.y=mid.y+c;
    }
    else{
        ang=atan(-p3.x/p3.y);
        centre.x=mid.x+c*cos(ang);
        centre.y=mid.y+c*sin(ang);
    }
    return centre;
}
int main(){
    int n,ans,tmpans,i,j,k;
    point p[305],centre;
    double tmp;
    while(~scanf("%d",&n)&&n){
        for(i=0;i<n;i++)
            scanf("%lf%lf",&p[i].x,&p[i].y);
        ans=1;
        for(i=0;i<n;i++){
            for(j=i+1;j<n;j++){
                if(dis(p[i],p[j])>4)
                    continue;
                tmpans=0;
                centre=find_centre(p[i],p[j]);
                for(k=0;k<n;k++){
                    tmp=dis(centre,p[k]);
                    if(tmp<=1.000001)
                        tmpans++;
                }
                if(ans<tmpans)
                    ans=tmpans;
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值