hdu 5410 CRB and His Birthday(01背包+完全背包)

CRB and His Birthday
Problem Description
Today is CRB's birthday. His mom decided to buy many presents for her lovely son.
She went to the nearest shop with  M  Won(currency unit).
At the shop, there are  N  kinds of presents.
It costs  Wi  Won to buy one present of  i -th kind. (So it costs  k  ×  Wi  Won to buy  k  of them.)
But as the counter of the shop is her friend, the counter will give  Ai × x + Bi  candies if she buys  x ( x >0) presents of  i -th kind.
She wants to receive maximum candies. Your task is to help her.
1 ≤  T  ≤ 20
1 ≤  M  ≤ 2000
1 ≤  N  ≤ 1000
0 ≤  Ai, Bi  ≤ 2000
1 ≤  Wi  ≤ 2000
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:
The first line contains two integers  M  and  N .
Then  N  lines follow,  i -th line contains three space separated integers  Wi Ai  and  Bi .
 

Output
For each test case, output the maximum candies she can gain.
 

Sample Input
   
   
1 100 2 10 2 1 20 1 1
 

Sample Output
   
   
21
Hint
CRB's mom buys 10 presents of first kind, and receives 2 × 10 + 1 = 21 candies.
 

Author
KUT(DPRK)
 

Source



思路: 对于每一个礼物,第一次买是01背包,以后再买就是完全背包(因为要保持不论买多少件这个礼物,都只加一次bi)

代码:
#include<stdio.h>
#include<string.h>

#define maxn 2000+10
#define max(a,b) (a>b?a:b)
int dp[maxn];

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        int m,n;
        scanf("%d%d",&m,&n);
        int i,j,w,a,b;
        for(i=0;i<n;i++)
        {
            scanf("%d%d%d",&w,&a,&b);
            for(j=m;j>=w;j--)
                dp[j]=max(dp[j],dp[j-w]+a+b);
            for(j=w;j<=m;j++)
                dp[j]=max(dp[j],dp[j-w]+a);
        }
        int ans=-1;
        for(i=0;i<=m;i++)
            ans=max(ans,dp[i]);
        printf("%d\n",ans);
    }
    return 0;
}


总结:一开始以为最多买2000件,所以直接用多重背包写的,可是最后bi却无法保证加到正确的位置上0.0
原来这种包含只加一次和可以加多次的权值的话可以用01背包+完全背包的方法写
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值