hdu 1250 Hat's Fibonacci(大数)

Hat's Fibonacci
Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
 

Input
Each line will contain an integers. Process to end of file.
 

Output
For each case, output the result in a line.
 

Sample Input
   
   
100
 

Sample Output
   
   
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.


ps:二维数组直接模拟大数加法,每一行表示一个数,每一行的每一个元素又可以代表n位数(n视情况任意而定),注意范围要大一点就好了

代码:
#include<stdio.h>

#define N 10000+10
int a[N][600+10];

void Fibonacci()
{
    int i,j,k=0;
    a[1][0]=a[2][0]=a[3][0]=a[4][0]=1;
    for(i=5; i<N; i++)
    {
        for(j=0; j<600; j++)
        {
            k+=a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
            a[i][j]=k%10000;
            k/=10000;
        }
    }
}

int main()
{
    Fibonacci();
    int n;
    while(~scanf("%d",&n))
    {
        int i,j;
        for(i=600; i>=0; i--)
            if(a[n][i])
                break;
        printf("%d",a[n][i]);
        for(j=i-1; j>=0; j--)
            printf("%04d",a[n][j]);//注意0的输出
        printf("\n");
    }
    return 0;
}



总结:以前的想法太狭隘了,只是把二位数组的每一个单元存一个一位数,这次学到了二维数组的每一个单元可以存n位数的方法
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值