HDOJ-----2199二分

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16580    Accepted Submission(s): 7363


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 


Sample Output
  
  
1.6152 No solution!

简单二分,从1到100二分,求函数的实数解,由数学知识函数图像大致是在0~100的上升曲线

#include<cstdio>
double nu(double a){
    return 8 * a * a * a * a + 7 * a * a * a + 2 * a * a + 3 * a + 6;//这里用pow也可以
}
void two(double t){
    double s, e, m;
    s = 0;
    e = 100;
    if(nu(0) > t || nu(100) < t){//x大于0时是增函数,必定有一个取值范围
        printf("No solution!\n");
        return ;
    }
    while(nu(e) - nu(s) > .00001){//二分区间点端点差小于10^-4,保险起见,再往后精确一位,其中间值mid就满足题意精度
        m = (s + e) / 2;
        if(nu(m) > t){
            e = m;
        }
        else{
            s = m;
        }
    }
    printf("%.4lf\n", m);
}
int main(){
    int a, k = 1;
    double u;
    scanf("%d", &a);
    while(a--){
        scanf("%lf", &u);
        two(u);
    }
    return 0;
}



Sample Output
   
   
1.6152 No solution!
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值