hdu 5666 Segment(快速乘)

42 篇文章 0 订阅
3 篇文章 0 订阅
Problem Description
     Silen August does not like to talk with others.She like to find some interesting problems.

     Today she finds an interesting problem.She finds a segment  x+y=q .The segment intersect the axis and produce a delta.She links some line between  (0,0)  and the node on the segment whose coordinate are integers.

     Please calculate how many nodes are in the delta and not on the segments,output answer mod P.
 

Input
     First line has a number,T,means testcase number.

     Then,each line has two integers q,P.

    q  is a prime number,and  2q1018,1P1018,1T10.
 

Output
     Output 1 number to each testcase,answer mod P.
 

Sample Input
  
  
1 2 107
 

Sample Output
  
  
0

solution:

推出公式为ans=(q-1)*(q-2)%p;但因为乘法会爆longlong,因此可用快速乘或Java

快速乘:

#include<cstdio>
#include<algorithm>
using namespace std;
typedef long long ll;
ll p, q;
ll pow(ll x,ll y)
{
    ll ans = 0;
    while (y)
    {
        if (y%2==1)ans=(ans+x)%p;
        x =(x+x)%p;
        y >>= 1;
    }
    return ans%p;
}
int main()
{
    int t;
    scanf("%d", &t);
    while (t--)
    {
        scanf("%I64d%I64d", &q, &p);
        if (q%2==1)printf("%I64d\n", pow(q - 2, (q - 1) / 2));
        else printf("%I64d\n", pow(q - 1, (q - 2) / 2));
    }
    return 0;
}

Java:

import java.math.BigInteger;
import java.util.*;
public class Main {
    public static void main(String[] args) {
        Scanner cin=new Scanner(System.in);
        BigInteger p,q,mod;
        BigInteger one=new BigInteger("1");
        BigInteger two=new BigInteger("2");
        int T;T=cin.nextInt();
        for(int i=0;i<T;i++)
        {
            q=cin.nextBigInteger();
            p=cin.nextBigInteger();
            System.out.println((((q.subtract(one)).multiply(q.subtract(two))).divide(two)).mod(p));
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值