HDU5666-Segment(大数水题)

 Silen August does not like to talk with others.She like to find some interesting problems.

Today she finds an interesting problem.She finds a segment x+y=q.The segment intersect the axis and produce a delta.She links some line between (0,0) and the node on the segment whose coordinate are integers.

Please calculate how many nodes are in the delta and not on the segments,output answer mod P.

Input
First line has a number,T,means testcase number.

Then,each line has two integers q,P.

q is a prime number,and 2≤q≤1018,1≤P≤1018,1≤T≤10.

Output
Output 1 number to each testcase,answer mod P.
Sample Input
1
2 107
Sample Output
0

分析:

题意:
给定一条斜率为-1的第一象限的直线,问与x轴和y轴组成的三角形中有多少个x坐标和y坐标都是整数的点(不包括x轴、y轴和直线上的点)?最后的结果对p取余。

解析:
题很水,就是个等差数列的的公式:n(n-1)/2

代码:

#include<iostream>
#include<cstdio>
#define N 100

using namespace std;

long long list[N];

int main()
{
	long long T,q,p;
	scanf("%lld",&T);
	while(T--)
	{
		scanf("%lld%lld",&q,&p);
		if(q==2)
			printf("0\n");
		else
		{
			int len=0;
			long long v=q-1,sum=0,k=q-2;
			if(v%2)
				k/=2;
			else
				v/=2;
			while(v)
			{
				list[++len]=v%10;
				list[len]*=k;
				v/=10;
			}
			while(len)
			{
				sum=list[len--]+sum*10;
				sum%=p;
			}
			printf("%lld\n",sum);
		}
	}
	return 0;
 }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值