hdu1042N!(大数)

N!

Time Limit : 10000/5000ms (Java/Other)   Memory Limit : 262144/262144K (Java/Other)
Total Submission(s) : 2   Accepted Submission(s) : 1
Problem Description
Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!
 

Input
One N in one line, process to the end of file.
 

Output
For each N, output N! in one line.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 6
 此题为大数的阶乘,主要方法就是用数组来不断存储计算好的阶乘,若i=1、2、3、4.......n;每次乘 i 都相当于模拟我们平常计算两个数相乘,直到乘到n.代码如下:
#include<stdio.h>
#include<string.h>
#define MAX 36010
int a[MAX];             //定义一个数组用来存储不断更新的阶乘的各位数;
int main()
{
	int n;
	int i,j,k,s;
	while(scanf("%d",&n)!=EOF)
	{
		memset(a,0,sizeof(a));
		a[0]=1;
		k=0;
		for(i=2;i<=n;i++)     //用来从2到n;
		{
			for(j=0;j<=MAX;j++)
			{
				s=a[j]*i+k;    //计算i与当前数的各位数相乘并加上进位的数K;
				a[j]=s%10;     //将当前的阶乘的各位数字依次存到数组a中;
				k=s/10;        //去除末尾的数;
			}
		}
		for(i=MAX;i>=0;i--)
		 if(a[i]>0)  break;
		for(j=i;j>=0;j--)
		 printf("%d",a[j]);
		printf("\n");
	}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值