hdu1028 Ignatius and the Princess III(母函数)

Ignatius and the Princess III
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says. 

"The second problem is, given an positive integer N, we define an equation like this: 
  N=a[1]+a[2]+a[3]+...+a[m]; 
  a[i]>0,1<=m<=N; 
My question is how many different equations you can find for a given N. 
For example, assume N is 4, we can find: 
  4 = 4; 
  4 = 3 + 1; 
  4 = 2 + 2; 
  4 = 2 + 1 + 1; 
  4 = 1 + 1 + 1 + 1; 
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!" 
 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file. 
 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found. 
 

Sample Input

       
       
4 10 20
 

Sample Output

       
       
5 42 627
 




题目大意:本题就是求一个数的划分的方案数(即可被拆分为多少种几个数相加的形式)
解题方法:本题有两种解法,一个是利用动态规划,一个是母函数。
母函数:
首先,母函数的形式为:G(x) = A0 + A1*x + A2*x^2 + A3*x^3 +..........+ An*x^n
其中每一项x的系数A[i]表示能组合成x的幂数i的方案数;(应用到本题A[i]就是能组合成n的方案数,而幂数x对应数n)
再看4的划分:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 +1 + 1;
则可的一个数n用母函数表示为就是:
1 + x + x^2 + x^3 + .........
1 + x^2 + x^4 + x^6 +.....
1 + x^3 + x^6 + x^9+........
     .
     .
     .
     .
1 + x^n + x^2*n +...........
这些多项式相乘,展开后x^n的系数就是将n划分的所有方案数。
用代码实现就需要用到两个数组a1[]和a2[],其中a 1[ ]保存当前得到的多项式各项系数,
a2[ ]保存每次计算时的临时结果,当每次计算完毕后,把它赋给a1[],然后a2清零.
#include<stdio.h>
#include<string.h>
#define M 5000
int a1[M],a2[M];
int main()
{
	int n;
	int i,j,k;
	while(scanf("%d",&n)!=EOF)
	{
		memset(a2,0,sizeof(a2));
		for(i=0;i<=n;i++)
		 a1[i]=1;
		for(i=2;i<=n;i++)
		{
			for(j=0;j<=n;j++)
			{
				for(k=0;k+j<=n;k+=i)
				  a2[k+j]+=a1[j];
			}
			for(j=0;j<=n;j++)
			{
				a1[j]=a2[j];
				a2[j]=0;
			}
		}
	printf("%d\n",a1[n]);	
	}
return 0;
}
下面是网上用动归的解法:

#include<cstdio>  
#include<cstring>  
#include<string>  
#include<iostream>  
#include<cmath>  
#include<algorithm>  
using namespace std;  
int dp[125][125],ans[125];  
int main()  
{  
    int n;  
    for(int i=0;i<121;i++)  
    {  
        dp[i][i]=1;  
    }  
    for(int i=1;i<121;i++)  
    {  
        for(int j=1;j<=i;j++)  
        {  
            if(i!=j)  
            dp[i][j]=dp[i-j][j]+dp[i-1][j-1];  
            ans[i]+=dp[i][j];  
        }  
    }  
    while(scanf("%d",&n)!=EOF)  
    {  
        printf("%d\n",ans[n]);  
    }  
    return 0;  
}  



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值