NYOJ248(贪心)

18 篇文章 0 订阅

BUYING FEED

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 4
描述

Farmer John needs to travel to town to pick up K (1 <= K <= 100)pounds of feed. Driving D miles with K pounds of feed in his truck costs D*K cents.

The county feed lot has N (1 <= N<= 100) stores (conveniently numbered 1..N) that sell feed. Each store is located on a segment of the X axis whose length is E (1 <= E <= 350). Store i is at location X_i (0 < X_i < E) on the number line and can sell John as much as F_i (1 <= F_i <= 100) pounds of feed at a cost of C_i (1 <= C_i <= 1,000,000) cents per pound.
Amazingly, a given point on  the X axis might have more than one store.

Farmer John  starts  at location 0 on this number line and can drive only in the positive direction, ultimately arriving at location E, with at least K pounds of feed. He can stop at any of the feed stores along the way and buy any amount of feed up to the the store's limit.  What is the minimum amount Farmer John has to pay to buy and transport the K pounds of feed? Farmer John
knows there is a solution.
 Consider a sample where Farmer John  needs two pounds of feed from three stores (locations: 1, 3, and 4) on a number line whose range is 0..5:     
0   1   2  3   4   5
    
---------------------------------
         
1       1   1                Available pounds of feed
         
1       2   2               Cents per pound

It is best for John to buy one pound of feed from both the second and third stores. He must pay two cents to buy each pound of feed for a total cost of 4. When John travels from 3 to 4 he is moving 1 unit of length and he has 1 pound of feed so he must pay1*1 = 1 cents.

When John travels from 4 to 5 heis moving one unit and he has 2 pounds of feed so he must pay 1*2 = 2 cents. The total cost is 4+1+2 = 7 cents.

输入
The first line of input contains a number c giving the number of cases that follow
There are multi test cases ending with EOF.
Each case starts with a line containing three space-separated integers: K, E, and N
Then N lines follow :every line contains three space-separated integers: Xi Fi Ci
输出
For each case,Output A single integer that is the minimum cost for FJ to buy and transport the feed
样例输入
12 5 3                 3 1 24 1 21 1 1
样例输出
7
来源

第三届河南省程序设计大赛

//NYOJ248(贪心)
//题目大意:约翰要将k个物品从起点0运到终点E,已知在0~E上有n个商店,每个商店X[i]最多允许买F个物品。
// 且花费C[i]元钱。且每个物品每运一个单位长度花费1元钱。问最终完成任务需要最少花费的钱数。
//解题思路:首先,已知每个商店的位置和该商店物品的单价。那么就可以先计算出各个商店运送一个物品
//所花费的钱数。按升序排好序。从花费最少的商店开始运送,如果可以一次性运完,那直接运完。
//否则,剩余的交给下一个商店运送,直到所有物品运完为止,同时这样的花费就是最少的花费。 
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node 
{
	int x,c,p;       //记录商店的位置x,最大购物量c,单价p。 
	int sp;         //保存从商店x运一份所需的费用 
}ans[101];
int cmp(node a,node b)
{
  return a.sp<b.sp;	     
} 
int main()
{
	int t,e,n,k,sum,i;
	scanf("%d",&t);
	while(t--)
	{
		while(scanf("%d%d%d",&k,&e,&n)!=EOF)
		{
			memset(ans,0,sizeof(ans));
			for(i=0;i<n;i++)
			{
				scanf("%d%d%d",&ans[i].x,&ans[i].c,&ans[i].p);
				ans[i].sp=e-ans[i].x+ans[i].p;       //计算单个物品运送到终点的费用 
			}
			sort(ans,ans+n,cmp);     //升序排序 
			i=sum=0;
			while(k>0)
			{
			   if(ans[i].c>=k)     //当前可以运完,直接运完。 
			   {
			   	  sum+=ans[i].sp*k;
			   	  k=0;
			   }
			   else                  //否则,将尽可能多的物品运到目的地。 
			   {
			      k-=ans[i].c;
				  sum+=ans[i].sp*ans[i].c;
				  i++;	                   //继续下一个商店。 
			   }	
			}
		printf("%d\n",sum);
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值