NYOJ58最少步数(bfs)

22 篇文章 0 订阅

最少步数

时间限制: 3000 ms  |  内存限制: 65535 KB
难度: 4
描述

这有一个迷宫,有0~8行和0~8列:

 1,1,1,1,1,1,1,1,1
 1,0,0,1,0,0,1,0,1
 1,0,0,1,1,0,0,0,1
 1,0,1,0,1,1,0,1,1
 1,0,0,0,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,1,0,0,1
 1,1,0,1,0,0,0,0,1
 1,1,1,1,1,1,1,1,1

0表示道路,1表示墙。

现在输入一个道路的坐标作为起点,再如输入一个道路的坐标作为终点,问最少走几步才能从起点到达终点?

(注:一步是指从一坐标点走到其上下左右相邻坐标点,如:从(3,1)到(4,1)。)

输入
第一行输入一个整数n(0<n<=100),表示有n组测试数据;
随后n行,每行有四个整数a,b,c,d(0<=a,b,c,d<=8)分别表示起点的行、列,终点的行、列。
输出
输出最少走几步。
样例输入
2
3 1  5 7
3 1  6 7
样例输出
12
11
题目大意:给你一个9X9的地图,输入起点坐标和终点坐标。求从起点到终点的最短距离。
解题思路:bfs搜索从起点到终点的最小步数。刚开始没有考虑终点和起点相等时的情况,wa了几次,加上后就A啦。
AC代码:
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
int vis[9][9];
int dx[4]={0,-1,1,0};
int dy[4]={1,0,0,-1}; 
int map[9][9]=
{1,1,1,1,1,1,1,1,1,
 1,0,0,1,0,0,1,0,1,
 1,0,0,1,1,0,0,0,1,
 1,0,1,0,1,1,0,1,1,
 1,0,0,0,0,1,0,0,1,
 1,1,0,1,0,1,0,0,1,
 1,1,0,1,0,1,0,0,1,
 1,1,0,1,0,0,0,0,1,
 1,1,1,1,1,1,1,1,1,
};
int x1,y1,x2,y2;
struct node{
	int x,y;
	int cnt;
};
bool jude(node s)
{
	if(s.x<0||s.x>=9||s.y<0||s.y>=9||map[s.x][s.y]==1)
	 return false;
return true;
}
int bfs(int x,int y)
{
	int minl=0x3f3f3f;
	node p,s;
	queue<node>q;
	p.x=x;
	p.y=y;
	p.cnt=0;
	q.push(p);
	vis[p.x][p.y]=1;
	while(!q.empty())
	{
		p=q.front();
		q.pop();
		for(int i=0;i<4;i++)
		{
			s.x=p.x+dx[i];
			s.y=p.y+dy[i];
			s.cnt=p.cnt+1;
			if(jude(s)&&!vis[s.x][s.y])
			{
				
				vis[s.x][s.y]=1;
				if(s.x==x2&&s.y==y2)
				{
					if(minl>s.cnt) minl=s.cnt;
				}
				else
				q.push(s);
			}
		}
	} 
return minl;
}
int main()
{
   int t;
   scanf("%d",&t);
   while(t--)
   {
   	memset(vis,0,sizeof(vis));
   	scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
	if(map[x1][y1]==1||map[x2][y2]==1)
	 continue; 
	if(x1==x2&&y1==y2&&map[x1][y1]!=1) //当起点和终点相等时,直接输出0.
	{
		printf("0\n");
		continue;
	}
   	int cnt=bfs(x1,y1);
   	printf("%d",cnt);
   	if(t>0) printf("\n");
   } 
return 0;
}

 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值