hdu5463(基础)

43 篇文章 0 订阅

Clarke and minecraft

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 864    Accepted Submission(s): 430


Problem Description
Clarke is a patient with multiple personality disorder. One day, Clarke turned into a game player of minecraft. 
On that day, Clarke set up local network and chose create mode for sharing his achievements with others. Unfortunately, a naughty kid came his game. He placed a few creepers in Clarke's castle! When Clarke returned his castle without create mode, creepers suddenly blew(what a amazing scene!). Then Clarke's castle in ruins, the materials scattered over the ground. 
Clark had no choice but to pick up these ruins, ready to rebuild. After Clarke built some chests(boxes), He had to pick up the material and stored them in the chests. Clarke clearly remembered the type and number of each item(each item was made of only one type material) . Now Clarke want to know how many times he have to transport at least. 
Note: Materials which has same type can be stacked, a grid can store 64 materials of same type at most. Different types of materials can be transported together. Clarke's bag has 4*9=36 grids.
 

Input
The first line contains a number  T(1T10) , the number of test cases. 
For each test case: 
The first line contains a number  n , the number of items. 
Then  n  lines follow, each line contains two integer  a,b(1a,b500) a  denotes the type of material of this item,  b  denotes the number of this material.
 

Output
For each testcase, print a number, the number of times that Clarke need to transport at least.
 

Sample Input
  
  
2 3 2 33 3 33 2 33 10 5 467 6 378 7 309 8 499 5 320 3 480 2 444 8 391 5 333 100 499
 

Sample Output
  
  
1 2
//hdu5463(基础)
//题目大意:有n件物品,(可能有种类相同的物品)现在有一个背包,其内部有36个单元,每个单元可以放同类型
//的物品64个,问将所有物品从一处运到另一处需要多少次?
//解题思路:定义一个数组,将同类的物品归到一起.先求出每种物品需要多少个单元的总和,然后因为运一次也就是
//36个单元,所以除以36就是需要运的次数,不过需要注意物品不足放满36个单元,也需要一次. 
#include<stdio.h>
#include<string.h>
int main()
{
   int a[510],t,n,i,u,v,k;
   scanf("%d",&t);
   while(t--)
   {
   	  memset(a,0,sizeof(a));
      scanf("%d",&n);	
      for(i=0;i<n;i++)
      {
      	scanf("%d%d",&u,&v);
      	a[u]+=v;
	  }
	  k=0;
	  for(i=1;i<=500;i++)
	  {
	  	if(a[i]>0)
	  	{
	  	  if(a[i]%64>0) k+=a[i]/64+1;
		  else          k+=a[i]/64;
		}
	  }
	  if(k%36>0) k=k/36+1;
	  else       k=k/36;
	  printf("%d\n",k);
   }
   return 0;	
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值