hdu1372(bfs)

22 篇文章 0 订阅

Knight Moves

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9660    Accepted Submission(s): 5671


Problem Description
A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.
Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part. 

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b. 
 

Input
The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard. 
 

Output
For each test case, print one line saying "To get from xx to yy takes n knight moves.". 
 

Sample Input
  
  
e2 e4 a1 b2 b2 c3 a1 h8 a1 h7 h8 a1 b1 c3 f6 f6
 

Sample Output
  
  
To get from e2 to e4 takes 2 knight moves. To get from a1 to b2 takes 4 knight moves. To get from b2 to c3 takes 2 knight moves. To get from a1 to h8 takes 6 knight moves. To get from a1 to h7 takes 5 knight moves. To get from h8 to a1 takes 6 knight moves. To get from b1 to c3 takes 1 knight moves. To get from f6 to f6 takes 0 knight moves.
题目大意:在一个8X8的棋盘中,已知起点s和终点t,问马从起点到终点最少需要多少步?
起点一定可以到达终点.
解题思路:根据马走“日”的特点,当其在某个位置时,其可以向其周围的八个方向扩展.
即(-2,-1)(-2,1)(2,-1)(2,1)(1,-2)(1,2)(-1,-2)(-1,2)
bfs从八个方向搜索即可。
不过标记状态的数组vis要开成三维数组.vis[10][10][10],前两个用来存坐标,最后一位用来标记方向.这样就可以避免走重复的路,同时
不影响扩展出所有状态.如果只标记坐标的话无法搜索出所有状态.
代码:
#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm> 
using namespace std; 
struct node
{
	int x,y,step; 
};
int fun(char c)
{ 
	int i;
	switch(c)
	{
		case 'a': i=1;
		break;
		case 'b': i=2;
		break;
		case 'c': i=3;
		break;
		case 'd': i=4;
		break;
		case 'e': i=5;
		break;
		case 'f': i=6;
		break;
		case 'g': i=7;
		break;
		case 'h': i=8;
		break;	
	}
	return i;
}
int vis[10][10][10],ex,ey; 
int dx[8]={-2,-2,2,2,-1,-1,1,1};
int dy[8]={-1,1,-1,1,-2,2,-2,2}; 
int bfs(int sx,int sy) 
{
   	node p,s;
   	memset(vis,0,sizeof(vis)); 
   	queue<node>q;
   	p.x=sx,p.y=sy;
   	p.step=0; 
   	q.push(p);
   	while(!q.empty())
	{
		p=q.front();
		q.pop();
		if(p.x==ex&&p.y==ey) 
		{
			return p.step;
		} 
		for(int i=0;i<8;i++)
		{
			s.x=p.x+dx[i];
			s.y=p.y+dy[i];
			if(s.x>=1&&s.x<=8&&s.y>=1&&s.y<=8&&!vis[s.x][s.y][i])
			{
				vis[s.x][s.y][i]=1; 
				s.step=p.step+1;
				q.push(s);
			} 
	    }
	} 
   	
}
int main()
{
	int k,sx,sy;
	char s[4],t[4];
	while(scanf("%s %s",s,t)!=EOF)
	{
	   sx=fun(s[0]);
	   sy=s[1]-'0'; 
	   ex=fun(t[0]);
	   ey=t[1]-'0' ;
	   k=bfs(sx,sy);
	   printf("To get from %s to %s takes %d knight moves.\n",s,t,k); 
    }
    return 0;
} 
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值