PAT-A1139 First Contact 题目内容及题解

Unlike in nowadays, the way that boys and girls expressing their feelings of love was quite subtle in the early years. When a boy A had a crush on a girl B, he would usually not contact her directly in the first place. Instead, he might ask another boy C, one of his close friends, to ask another girl D, who was a friend of both B and C, to send a message to B -- quite a long shot, isn't it? Girls would do analogously.

Here given a network of friendship relations, you are supposed to help a boy or a girl to list all their friends who can possibly help them making the first contact.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N (1 < N ≤ 300) and M, being the total number of people and the number of friendship relations, respectively. Then M lines follow, each gives a pair of friends. Here a person is represented by a 4-digit ID. To tell their genders, we use a negative sign to represent girls.

After the relations, a positive integer K (≤ 100) is given, which is the number of queries. Then K lines of queries follow, each gives a pair of lovers, separated by a space. It is assumed that the first one is having a crush on the second one.

Output Specification:

For each query, first print in a line the number of different pairs of friends they can find to help them, then in each line print the IDs of a pair of friends.

If the lovers A and B are of opposite genders, you must first print the friend of A who is of the same gender of A, then the friend of B, who is of the same gender of B. If they are of the same gender, then both friends must be in the same gender as theirs. It is guaranteed that each person has only one gender.

The friends must be printed in non-decreasing order of the first IDs, and for the same first ones, in increasing order of the seconds ones.

Sample Input:

10 18
-2001 1001
-2002 -2001
1004 1001
-2004 -2001
-2003 1005
1005 -2001
1001 -2003
1002 1001
1002 -2004
-2004 1001
1003 -2002
-2003 1003
1004 -2002
-2001 -2003
1001 1003
1003 -2001
1002 -2001
-2002 -2003
5
1001 -2001
-2003 1001
1005 -2001
-2002 -2004
1111 -2003

Sample Output:

4
1002 2004
1003 2002
1003 2003
1004 2002
4
2001 1002
2001 1003
2002 1003
2002 1004
0
1
2003 2001
0

题目大意

题目给出一种情况,要求两人如想建立联系,需要有同性别朋友牵线搭桥。题目给出一个友谊关系的网络,要求帮助有需要的人列出所有可能帮助他们第一次接触的朋友。好友必须按照第一个id的非递减顺序输出;对于第一个id相同的情况,必须按照第二个id的递增顺序输出。

解题思路

  1. 初始化并读入数据,保存朋友关系,并将同性别朋友关系额外用邻接表保存。
  2. 读入每对想建立关系的名单;
  3. 对每对请求建立两层嵌套查询,分别查询其同性别朋友互相之间是否有联系(排除他们本人直接联系的渠道),并记录;
  4. 排序并按照题目要求的格式输出;
  5. 所有请求队列完成之后返回零值。

代码

#include<cstdio>
#include<vector>
#include<set>
#include<algorithm>
using namespace std;
#define maxn 10010

char g[maxn];//male-1;female-0;
set<int> st;
int N,M,K;
vector<int> Friend[maxn];//friend with same gender

struct Pair{
    int n1,n2;
};

vector<Pair> Pa;

bool cmp(Pair a,Pair b){
    if(a.n1!=b.n1){
        return a.n1<b.n1;
    }else{
        return a.n2<b.n2;
    }
}
int Tonum(char a[]){
    int num;
    if(a[0]=='-'){
        num=(a[1]-'0')*1000+(a[2]-'0')*100+(a[3]-'0')*10+(a[4]-'0');
    }else{
        num=(a[0]-'0')*1000+(a[1]-'0')*100+(a[2]-'0')*10+(a[3]-'0');
        g[num]=1;
    }
    return num;
}

void Init(){
    char a[10],b[10];
    int A,B;
    scanf("%d%d",&N,&M);
    while(M--){
        scanf("%s%s",a,b);
        A=Tonum(a);
        B=Tonum(b);
        st.insert(10000*A+B);
        st.insert(10000*B+A); 
        if(g[A]==g[B]){
            Friend[A].push_back(B);
            Friend[B].push_back(A);
        }
    }
    scanf("%d",&K);
}

int Abs(int a){
    return a<0?-a:a;
}

void Check(){
    int A,B;
    int i,j,m,n;
    Pair temp;
    scanf("%d%d",&A,&B);
    A=Abs(A);
    B=Abs(B);
    Pa.clear();
    for(i=0;i<Friend[A].size();i++){
        m=Friend[A][i];
        for(j=0;j<Friend[B].size();j++){
            n=Friend[B][j];
            if(m==B||n==A){
                continue;
            }
            if(st.find(10000*m+n)!=st.end()){
                temp.n1=m;
                temp.n2=n;
                Pa.push_back(temp);
            }
        }
    }
    printf("%d\n",Pa.size());
    sort(Pa.begin(),Pa.end(),cmp);
    for(i=0;i<Pa.size();i++){
        printf("%04d %04d\n",Pa[i].n1,Pa[i].n2);
    }
}

int main(){
    Init();
    while(K--){
        Check();
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值