PAT-A1149/B1090 Dangerous Goods Packaging/危险品装箱 题目内容及题解

When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化剂) must not be packed with flammable liquid (易燃液体), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

集装箱运输货物时,我们必须特别小心,不能把不相容的货物装在一只箱子里。比如氧化剂绝对不能跟易燃液体同箱,否则很容易造成爆炸。

本题给定一张不相容物品的清单,需要你检查每一张集装箱货品清单,判断它们是否能装在同一只箱子里。

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: N (≤10^​4​​), the number of pairs of incompatible goods, and M (≤100), the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

输入第一行给出两个正整数:N (≤10​^4​​) 是成对的不相容物品的对数;M (≤100) 是集装箱货品清单的单数。

随后数据分两大块给出。第一块有 N 行,每行给出一对不相容的物品。第二块有 M 行,每行给出一箱货物的清单,格式如下:

K G[1] G[2] ... G[K]

where K (≤1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

其中 K (≤1000) 是物品件数,G[i] 是物品的编号。简单起见,每件物品用一个 5 位数的编号代表。两个数字之间用空格分隔。

Output Specification:

For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

对每箱货物清单,判断是否可以安全运输。如果没有不相容物品,则在一行中输出 Yes,否则输出 No。

Sample Input:

6 3
20001 20002
20003 20004
20005 20006
20003 20001
20005 20004
20004 20006
4 00001 20004 00002 20003
5 98823 20002 20003 20006 10010
3 12345 67890 23333

Sample Output:

No
Yes
Yes

解题思路

  1. 读取并用vector列表保存违禁品信息;
  2. 对每个序列执行一次检查函数;
  3. 检查函数中初始化并读取每个序列并记录,并在vis数组上记录含有该物品;
  4. 对列表中的每个物品执行检查,判断其违禁品是否也在其中,如有,则输出不能并返回继续下一下检查;
  5. 如果没有危险品组合就输出可以,并继续下一次检查;
  6. 检查完成后返回零值。

代码

#include<cstdio>
#include<vector>
using namespace std;
#define maxn 100010
int N,M;
vector<int> Im[maxn];
vector<int> req;
vector<int> vis;

void Init(){
    int a,b;
    scanf("%d%d",&N,&M);
    while(N--){
        scanf("%d%d",&a,&b);
        Im[a].push_back(b);
        Im[b].push_back(a);
    }
}

void check(){
    int K,a,i,j;
    vector<int> temp;
    req.clear();
    vis.clear();
    vis.resize(maxn);
    scanf("%d",&K);
    while(K--){
        scanf("%d",&a);
        vis[a]=1;
        req.push_back(a);
    }
    for(i=0;i<req.size();i++){
        temp=Im[req[i]];
        for(j=0;j<temp.size();j++){
            if(vis[temp[j]]==1){
                printf("No\n");
                return;
            }
        }
    }
    printf("Yes\n");
}

int main(){
    Init();
    while(M--){
        check();
    }
    return 0;
}

运行结果

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值