Ping pong

Ping pong

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 106    Accepted Submission(s): 50

 
Problem Description
N(3<=N<=20000) ping pong players live along a west-east street(consider the street as a line segment).

Each player has a unique skill rank. To improve their skill rank, they often compete with each other. If two players want to compete, they must choose a referee among other ping pong players and hold the game in the referee's house. For some reason, the contestants can’t choose a referee whose skill rank is higher or lower than both of theirs.

The contestants have to walk to the referee’s house, and because they are lazy, they want to make their total walking distance no more than the distance between their houses. Of course all players live in different houses and the position of their houses are all different. If the referee or any of the two contestants is different, we call two games different. Now is the problem: how many different games can be held in this ping pong street?
Input
The first line of the input contains an integer T(1<=T<=20), indicating the number of test cases, followed by T lines each of which describes a test case.


Every test case consists of N + 1 integers. The first integer is N, the number of players. Then N distinct integers a1, a2 … aN follow, indicating the skill rank of each player, in the order of west to east. (1 <=  ai  <= 100000, i = 1 … N).
Output
For each test case, output a single line contains an integer, the total number of different games.
Sample Input
1
3 1 2 3
Sample Output
1
 
问题抽象为对于一个数组a[],输出在i这个位置,前面有ci个比ai小,后面有di个比ai小。再累加。
如果把比ai小的记为1,不小于的记为0,可以看到ci = x1 + x2 + ... + xi-1.从而用树状数组完成。原始树状数组横轴是1,2,3...n。现在横轴是ai...an.可以看到现在的横轴不是连续的。
此题的ai不是很大,因此不需要离散化。
 
#include<cstdio>
#include<cstring>
using namespace std;

const int MAXN = 100000 + 10;
int n, g[MAXN], v[MAXN];

int lower_bit(int x){
	return x & (-x);
}
void update(int i, int x){
	for(; i <= MAXN; i += lower_bit(i)){
		v[i] += x;
	}
}
int sum(int i){
	int s = 0;
	for(; i > 0; i -= lower_bit(i)){
		s += v[i];
	}
	return s;
}
int main(){
	int t;
	scanf("%d", &t);
	while(t--){
		scanf("%d", &n);
		for(int i = 1; i <= n; i++){
			scanf("%d", &g[i]);
		}
		memset(v, 0, sizeof(v));
		int l[MAXN], r[MAXN];  // r[i]表示在i左边,比他小的数。r[i]同理 
		for(int i = 1; i <= n; i++){	
			update(g[i], 1);		
			l[i] = sum(g[i]-1);	 
		}
		memset(v, 0, sizeof(v));
		for(int i = n; i > 0; i--){			
			update(g[i], 1);
			r[i] = sum(g[i]-1);		
		}
		__int64 ans = 0;  //数字大,用64位 
		for(int i = 1; i <= n; i++){
			ans += l[i] * (n - i - r[i]) + r[i] * (i - 1 - l[i]);
		}
		printf("%I64d\n", ans);
	}
	return 1;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值