Q1010 Tempter of the Bone C++ (深度优先搜索)

Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter;
'S': the start point of the doggie;
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
Sample Input
4 4 5
S.X.
..X.
..XD
....
3 4 5
S.X.
..X.
...D
0 0 0
Sample Output
NO
YES

本题用到深度优先搜索(DFS)的方法。基本思想就是:从某点出发,沿着一条路一直走,知道无路可走时,回溯一步,换条路继续走。该方法优点是:能较快的找到可行解;缺点是:找到的解并不一定的最优解。

代码如下:
<span style="font-family:Times New Roman;font-size:14px;">#include <iostream>
#include <cmath>
using namespace std;

char map[7][7];
int N, M, T;
int si, sj, di, dj, block;
bool flag;

int direc[4][2] = {-1,0,0,1,1,0,0,-1};

void dfs(int x, int y, int c)
{
	if (x == di && y == dj && c == T)
	{
		flag = 1;
		return;
	}
	if (x < 0 || x >= N || y < 0 || y >= M)
	{
		flag = 0;
		return;
	}
	if (abs(x - di) + abs(y - dj) > T - c)
	{
		flag = 0;
		return;
	}
	if ((T - c - abs(x - di) - abs(y - dj)) % 2 != 0)
	{
		flag = 0;
		return;
	}

		for (int i = 0; i < 4; i++)
		{
			if (x + direc[i][0] >= 0 && x + direc[i][0] < N && y + direc[i][1] >= 0 && y + direc[i][1] < M)
			{
				if (map[x + direc[i][0]][y + direc[i][1]] != 'X')
				{
					map[x + direc[i][0]][y + direc[i][1]] = 'X';
					dfs(x + direc[i][0], y + direc[i][1], c+1);
					if(flag)
						return;
					else
						map[x + direc[i][0]][y + direc[i][1]] = '.';
				}
			}
		}

}

int main()
{
	while(cin >> N >> M >> T)
	{
		flag = 0;
		block = 0;
		if (N == 0 && M == 0 && T == 0)
		{
			return 0;
		}

		for (int i = 0; i < N; i++)
		{
			for (int j = 0; j < M; j++)
			{
				cin >> map[i][j];

				if (map[i][j] == 'S')
				{
					si = i;
					sj = j;
				}
				else if (map[i][j] == 'D')
				{
					di = i;
					dj = j;
				}
				else if (map[i][j] == 'X')
				{
					block++;
				}
			}
		}

		if (N * M - block < T)
		{
			cout << "NO" << endl;
			continue;
		}
		map[si][sj] = 'X';
		dfs(si, sj, 0);

		if(flag)
			cout << "YES" << endl;
		else
			cout << "NO" << endl;

	}
	return 0;
}</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值