poj 2312 bfs+优先队列 入门题

点击打开链接

Battle City
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9269 Accepted: 3068

Description

Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 

What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 

Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

Input

The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

Output

For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

Sample Input

3 4
YBEB
EERE
SSTE
0 0

Sample Output

8
题意:计算从Y走到T的最短距离,S和R不能走,走过E需要一步,走过B需要两步,优先队列模板题

#include<cstdio>
#include<cstring>
#include<queue>
using namespace std;
struct node
{
	int x,y,step;
	bool friend operator<(node c,node d)//优先队列比普通bfs就多了这个地方 
	{
		return c.step>d.step;//表示步数小的优先出队列 
	}
}no,ne;
char Map[301][301];
int vis[301][301];
int n,m,move[4][2]={1,0,-1,0,0,1,0,-1};
int flag;
void bfs(int x,int y)
{
	priority_queue<node>q;
	no.x=x,no.y=y,no.step=0;
	q.push(no);
	while(!q.empty())
	{
		no=q.top();
		q.pop();
		if(Map[no.x][no.y]=='T')
		{
			printf("%d\n",no.step);
			flag=1;
			return;
		}
		//vis[no.x][no.y]=1  注意不能在这里标记,否则会超时,这种标记已经走过的点会重复进队 
		for(int i=0;i<4;i++)
		{
			ne.x=no.x+move[i][0];
			ne.y=no.y+move[i][1];
			if(vis[ne.x][ne.y]||ne.x<0||ne.x>=n||ne.y<0||ne.y>=m)
			continue;
			if(Map[ne.x][ne.y]=='R'||Map[ne.x][ne.y]=='S')
			continue;
			vis[ne.x][ne.y]=1;
			if(Map[ne.x][ne.y]=='B')
			ne.step=no.step+2;
			else
			ne.step=no.step+1;
			q.push(ne);
		}
	}
}
int main()
{
	while(~scanf("%d%d",&n,&m)&&n&&m)
	{
		for(int i=0;i<n;i++)
		scanf("%s",&Map[i]);
		memset(vis,0,sizeof(vis));
		flag=0;
		for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)
		if(Map[i][j]=='Y')
		bfs(i,j);
		if(!flag)
		printf("-1\n");
	}
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

长沙橘子猫

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值