poj 2785 4 Values whose Sum is 0

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 228 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input
6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output
5


【分析】
呼呼呼,又是一道数字哈希
让我们两段两段的考虑吧
就考虑 a[i]+b[j] 和 c[p]+d[q] 是否相等
将上述两个值分别哈希
然后查询就好咯hohoho


【代码】

//poj 2785 零和游戏 
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<iomanip>
#include<cmath>
#define fo(i,j,k) for(i=j;i<=k;i++)
using namespace std;
const int N=4001;
const int H=20345677;
const int MAX=1000000000;
const int key=1;
int a[N],b[N],c[N],d[N];
int hash[H+1],sum[H+1];
void insert(int num)
{
    int tmp=num;
    num=(num+MAX)%H;
    while(hash[num]!=MAX && hash[num]!=tmp)
      num=(num+key)%H;
    hash[num]=tmp;
    sum[num]++;
}
int find(int num)
{
    int tmp=num;
    num=(num+MAX)%H;
    while(hash[num]!=MAX && hash[num]!=tmp)
      num=(num+key)%H;
    if(hash[num]==MAX) return 0;
    return sum[num];
}
int main()
{
    int n,i,j,k,tot=0;
    fo(i,0,H) hash[i]=MAX;
    scanf("%d",&n);
    fo(i,1,n)
      scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
    fo(i,1,n)
      fo(j,1,n)
        insert(a[i]+b[j]);
    fo(i,1,n)
      fo(j,1,n)
        tot+=find(-c[i]-d[j]);
    printf("%d\n",tot);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值