HDU 1250-Hat's Fibonacci(大数)

address:http://acm.hdu.edu.cn/showproblem.php?pid=1250
Problem Description
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.

Input
Each line will contain an integers. Process to end of file.

Output
For each case, output the result in a line.

Sample Input
100

Sample Output
4203968145672990846840663646

Note:
No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.

code:

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;
int a[8001][260];
int main ()
{
    int i,j;
     memset(a,0,sizeof(a));
    a[1][0]=1;
    a[2][0]=1;
    a[3][0]=1;
    a[4][0]=1;
    for (i=5;i<=8000;i++)
    {
        for (j=0;j<260;j++)
        {
            a[i][j] += a[i-1][j]+a[i-2][j]+a[i-3][j]+a[i-4][j];
        }
        for(j=0;j<260;j++)                //每八位考虑进位。
            if(a[i][j]>100000000)
            {
                a[i][j+1]+=a[i][j]/100000000;
                a[i][j]=a[i][j]%100000000;
            }
    }
   // cout<<count<<endl;
    int x;
    while (cin>>x)
    {
        int flag=0;
        for (i=259;i>=0;i--)
        {
            if (a[x][i]!=0)
                break;
        }
       printf("%d",a[x][i]);
        for (i--;i>=0;i--)
        {
            printf ("%08d",a[x][i]);
        }
        cout<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值