Can you find it? HDU - 2141

Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
给你三个数字序列A,B,C,然后给您一个数字X。现在您需要计算是否可以找到满足公式Ai + Bj + Ck = X的三个数字Ai,Bj,Ck。

Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
有很多情况。每个数据情况描述如下:第一行中有三个整数L,N,M,第二行中有L个整数代表序列A,第三行中有N个整数代表序列B,在第四行有M个整数表示序列C。第五行有一个整数S表示有S个要计算的整数X。1≤L,N,M≤500、1≤S≤1000。

Output

For each case, firstly you have to print the case number as the form “Case d:”, then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print “YES”, otherwise print “NO”.
对于每种情况,首先必须以“ Case d:”形式打印案例号,然后对于S查询,计算是否可以满足公式,满足输出YES,否则输出NO.
Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10

Sample Output

Case 1:
NO
YES
NO
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
int d[250005];
int main() {
	int l,m,n,find,x,flag;
	int a[505],b[505],c[505];
	int order=1;
	while(~scanf("%d %d %d",&l,&m,&n)) {
		for(int i=0; i<l; i++) {
			scanf("%d",&a[i]);
		}
		for(int i=0; i<m; i++) {
			scanf("%d",&b[i]);
		}
		for(int i=0; i<n; i++) {
			scanf("%d",&c[i]);
		}
		printf("Case %d:\n",order);
		order++;
		int p=0;
		for(int i=0; i<l; i++) {
			for(int j=0; j<m; j++) {
				d[p++]=a[i]+b[j];
			}
		}
		sort(d,d+p);
		scanf("%d",&find);
		while(find--) {
			scanf("%d",&x);
			flag=0;
			for(int k=0; k<n; k++) {
				if(binary_search(d,d+p,x-c[k])) {
					flag=1;
					break;
				}
			}
			if(flag==1) {
				printf("YES\n");
			} else {
				printf("NO\n");
			}
		}
	}
	return 0;
}

参考:https://blog.csdn.net/Aibiabcheng/article/details/103858124

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值