深度优先搜索(dfs)的用法——lake counting

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

问题描述:

有一个大小为N*M的园子,雨后积了很多水。八连通的积水被认为是在一起的。请求出园子里共有多少个水洼?(八连通是指下图中相对+的*部分)

+++

+*+

+++

解题分析:

    从任意的’+’开始,不停地把邻接的部分用’*’代替,一次dfs(深度优先遍历)遍历后,与初始的这个+所连接的所有+都会被替换成*,因此直到图中没有+为止,总共进行dfs的次数即为积水的次数。

#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;
char a[1001][1001];
int n,m;
void DFS(int x,int y)
{
    int i,j,b,c;
    for(i=-1;i<=1;i++){
        for(j=-1;j<=1;j++){
            b=i+x;//代表了八个方向  (i-1,j-1)  (i-1,j)  (i-1,j+1) (i,j-1)
            c=y+j;//		  (i,j+1)   (i+1,j-1)  (i+1,j)  (i+1,j+1)
            if(b>=0&&b<n&&y>=0&&y<m&&a[b][c]=='W')
            {
                a[b][c]='.';//如果改点是 ’W' 的话 就另 该点是 '.' 以后也不访问他
                DFS(b,c);// 去搜索该点
            }
        }
    }
}
int main()
{
    int i,j,flag=0;
    while(scanf("%d %d",&n,&m)!=EOF){
        memset(a,'0',sizeof(a));
        flag=0;
        for(i=0;i<=n-1;i++)
            scanf("%s",a[i]);
        for(i=0;i<=n-1;i++){
            for(j=0;j<=m-1;j++){
                if(a[i][j]=='W'){
                    flag++;//遇见一个水洼 就加加
                    DFS(i,j);//去搜索这一点的八个方向
                }
            }
        }
        printf("%d\n",flag);
    }
return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值