Find them, Catch them POJ - 1703 (种类并查集(影子并查集))

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

题目大意:

  • t组数据,一个n,一个q,代表n个人,q组操作。
  • A a b代表查询a b是否在同一集团里,D a b代表是a b不是同一个集团。

解题思路

  • 影子并查集,D a b代表a b不是一个集合,
  • 那么把a和b+n放到一个集合,
  • b和a+n放在一个集合,就分开了a和b。
  • 哦呵呵,这想法也太强大啦~~~~

 超超爱爱~~~~并查集~~~模板

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=1e6+10;
int n,m;
int s[maxn];
int height[maxn];         //用height[i]定义元素i的高度

int find_set(int x)
{
    int r = x;
    while ( s[r] != r ) r=s[r]; //找到根结点
    int i = x, j;
    while(i != r)
    {
        j = s[i]; //用临时变量j记录
        s[i]= r ; //把路径上元素的集改为根结点
        i = j;
    }
    return r;
}

void init_set()
{
    for(int i = 1; i <= n*2; i++)
    {
        s[i] = i;
        height[i]=0;       //初始化树的高度
    }
}
void union_set(int x, int y)     //优化合并操作
{
    x = find_set(x);
    y = find_set(y);
    if (height[x] == height[y])
    {
        height[x] = height[x] + 1;  //合并,树的高度加1
        s[y] = x;
    }
    else       //把矮树并到高树上,高树的高度保持不变
    {
        if (height[x] < height[y])  s[x] = y;
        else   s[y] = x;
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&n,&m);
        init_set();
        while(m--)
        {
            char c[6];
            int x,y;
            scanf("%s%d%d",c,&x,&y);
            if(c[0]=='A')
            {
                if(find_set(x)==find_set(y))
                {
                    printf("In the same gang.\n");
                }
                else
                {
                    if(find_set(x)==find_set(y+n)||find_set(x+n)==find_set(y))
                    {
                        printf("In different gangs.\n");
                    }
                    else
                    {
                        printf("Not sure yet.\n");
                    }
                }
            }
            else
            {
                union_set(x,y+n);
                union_set(x+n,y);

            }
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值