A Bug's Life POJ - 2492

Background 
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem 
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

题意:

  • n个虫子,m对关系,每对关系代表着相恋,
  • 看分类对不对,不存在同性恋(无真爱。。。。);

思路:

  • 假设x与x+n是相反的性别,因此需要开2*n的数组 
  • 通过并查集将同一性别的放在一个集合,设A与B交配,
  • 那么判断A与B或者A+n与B+n是否为异性,
  • 一旦出现同性相交往后就只读数据不用测试了。

超超爱爱~~~并查集模板 

#include <iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn=2000+10;
int flas;
int n,m;
int s[2*maxn];
int height[2*maxn];         //用height[i]定义元素i的高度

int find_set(int x)
{
    int r = x;
    while ( s[r] != r ) r=s[r]; //找到根结点
    int i = x, j;
    while(i != r)
    {
        j = s[i]; //用临时变量j记录
        s[i]= r ; //把路径上元素的集改为根结点
        i = j;
    }
    return r;
}

void init_set()
{
    for(int i = 1; i <= n*2; i++)
    {
        s[i] = i;
        height[i]=0;       //初始化树的高度
    }
}

void union_set(int x, int y)     //优化合并操作
{
    x = find_set(x);
    y = find_set(y);
    if (height[x] == height[y])
    {
        height[x] = height[x] + 1;  //合并,树的高度加1
        s[y] = x;
    }
    else       //把矮树并到高树上,高树的高度保持不变
    {
        if (height[x] < height[y])  s[x] = y;
        else   s[y] = x;
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    int l=0;
    while(t--)
    {
        flas=0;
        scanf("%d%d",&n,&m);
        init_set();
        while(m--)
        {
            int x,y;
            scanf("%d%d",&x,&y);
            if(find_set(x)==find_set(y))
            {
                flas=1;
            }
            else
            {
                union_set(x,y+n);
                union_set(x+n,y);
            }

        }
        l++;
        printf("Scenario #%d:\n",l);
        if(flas==1)
            printf("Suspicious bugs found!\n\n");
        else
            printf("No suspicious bugs found!\n\n");
    }

    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值