-----暴力搜索-hdu 5952 Counting Cliques

A clique is a complete graph, in which there is an edge between every pair of the vertices. Given a graph with N vertices and M edges, your task is to count the number of cliques with a specific size S in the graph.
Input
The first line is the number of test cases. For each test case, the first line contains 3 integers N,M and S (N ≤ 100,M ≤ 1000,2 ≤ S ≤ 10), each of the following M lines contains 2 integers u and v (1 ≤ u < v ≤ N), which means there is an edge between vertices u and v. It is guaranteed that the maximum degree of the vertices is no larger than 20.
Output
For each test case, output the number of cliques with size S in the graph.
Sample Input
3
4 3 2
1 2
2 3
3 4
5 9 3
1 3
1 4
1 5
2 3
2 4
2 5
3 4
3 5
4 5
6 15 4
1 2
1 3
1 4
1 5
1 6
2 3
2 4
2 5
2 6
3 4
3 5
3 6
4 5
4 6
5 6
Sample Output
3
7
15
….瞎写然后就过了

#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <vector>
#include <algorithm>
using namespace std;

const int maxn=905;
const int M=9005;
int n,m,s;
int ans,flag,coun;
vector<int>g[M];
int pos[maxn],vis[maxn][maxn];

void dfs(int u)
{
    if(coun==s)
    {
        ans++;
        return;
    }
    for(int i=0; i<g[u].size(); i++)
    {
        int to=g[u][i];
        for(int k=1; k<=coun; k++)
        {
            flag=0;
            if(vis[to][pos[k]]==0||vis[pos[k]][to]==0)
            {
                flag=1;
                break;
            }
        }
        if(flag==0)
        {
            coun++;
            pos[coun]=to;
            dfs(to);
            pos[coun]=0;
            coun--;
        }
    }
}

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        for(int i=0;i<=n;i++)
            g[i].clear();
        memset(vis,0,sizeof(vis));
        int x,y;
        scanf("%d%d%d",&n,&m,&s);
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&x,&y);
            vis[x][y]=1;
            vis[y][x]=1;
             g[x].push_back(y);
        }
        ans=0;
        for(int i=1; i<=n; i++)
        {
            coun=1;
            for(int j=0;j<=n;j++)
            {
                  if(j==1) pos[j]=i;
            else pos[j]=0;
            }
            dfs(i);
        }
        printf("%d\n",ans);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值