LCM WalkTime Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)Total Submission(s): 17 Accepted Submission(s): 10
Problem Description
A frog has just learned some number theory, and can't wait to show his ability to his girlfriend.
Now the frog is sitting on a grid map of infinite rows and columns. Rows are numbered 1,2,⋯ from the bottom, so are the columns. At first the frog is sitting at grid (sx,sy) , and begins his journey. To show his girlfriend his talents in math, he uses a special way of jump. If currently the frog is at the grid (x,y) , first of all, he will find the minimum z that can be divided by both x and y , and jump exactly z steps to the up, or to the right. So the next possible grid will be (x+z,y) , or (x,y+z) . After a finite number of steps (perhaps zero), he finally finishes at grid (ex,ey) . However, he is too tired and he forgets the position of his starting grid! It will be too stupid to check each grid one by one, so please tell the frog the number of possible starting grids that can reach (ex,ey) !
Input
First line contains an integer
T
, which indicates the number of test cases.
Every test case contains two integers ex and ey , which is the destination grid. ⋅ 1≤T≤1000 . ⋅ 1≤ex,ey≤109 .
Output
For every test case, you should output "
Case #x: y", where
x
indicates the case number and counts from
1
and
y
is the number of possible starting grids.
Sample Input
Sample Output
|
题意:在位置(x, y),可以走到(x+lcm(x, y), y) 或(x, y+lcm(x, y))或者不移动。给定终点位置,求可能的起点位置。
DFS暴力记录数据,找规律就行了。
对于互质的x和y假设x<y,(x, y)上一位置 -> (x, y / (x+1)),当y % (x+1) != 0时终止。
AC代码:
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <queue>
#include <stack>
#include <map>
#include <vector>
#define INF 0x3f3f3f
#define eps 1e-8
#define MAXN (100000+10)
#define MAXM (100000)
#define Ri(a) scanf("%d", &a)
#define Rl(a) scanf("%lld", &a)
#define Rf(a) scanf("%lf", &a)
#define Rs(a) scanf("%s", a)
#define Pi(a) printf("%d\n", (a))
#define Pf(a) printf("%.2lf\n", (a))
#define Pl(a) printf("%lld\n", (a))
#define Ps(a) printf("%s\n", (a))
#define W(a) while(a--)
#define CLR(a, b) memset(a, (b), sizeof(a))
#define MOD 1000000007
#define LL long long
#define lson o<<1, l, mid
#define rson o<<1|1, mid+1, r
#define ll o<<1
#define rr o<<1|1
using namespace std;
LL gcd(LL a, LL b){
return b == 0 ? a : gcd(b, a%b);
}
int main()
{
int t, kcase = 1; Ri(t);
W(t)
{
LL x, y;
Rl(x); Rl(y);
LL GCD = gcd(x, y);
x /= GCD; y /= GCD;
LL ans = 0;
while(1)
{
ans++;
if(x > y)
swap(x, y);
if(y % (x+1))
break;
y /= (x+1);
}
printf("Case #%d: %lld\n", kcase++, ans);
}
return 0;
}