CRB and His Birthday

                                          CRB and His Birthday

Description

Today is CRB's birthday. His mom decided to buy many presents for her lovely son. 
She went to the nearest shop with $M$ Won(currency unit). 
At the shop, there are $N$ kinds of presents. 
It costs $W_{i}$ Won to buy one present of $i$-th kind. (So it costs $k$ × $W_{i}$ Won to buy $k$ of them.) 
But as the counter of the shop is her friend, the counter will give $A_{i}\ ×\ x\ +\ B_{i}$ candies if she buys $x$($x$>0) presents of $i$-th kind. 
She wants to receive maximum candies. Your task is to help her. 
1 ≤ $T$ ≤ 20 
1 ≤ $M$ ≤ 2000 
1 ≤ $N$ ≤ 1000 
0 ≤ $A_{i},\ B_{i}$ ≤ 2000 
1 ≤ $W_{i}$ ≤ 2000 
 

Input

There are multiple test cases. The first line of input contains an integer $T$, indicating the number of test cases. For each test case: 
The first line contains two integers $M$ and $N$. 
Then $N$ lines follow, $i$-th line contains three space separated integers $W_{i}$, $A_{i}$ and $B_{i}$. 
 

Output

For each test case, output the maximum candies she can gain.
 

Sample Input

    
    
1 100 2 10 2 1 20 1 1
 

Sample Output

    
    
21

Hint

CRB's mom buys 10 presents of first kind, and receives 2 × 10 + 1 = 21 candies.
         
 
这道题要使用完全背包和01背包做,先01后完全和先完全后01都可以不影响。
代码:
#include<stdio.h>
#include<algorithm>
using namespace std;
struct pe
{
    int w,a,b;
} p[20005];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int m,n,d[20005]= {0};
        scanf("%d%d",&m,&n);
        for(int i=0; i<n; i++)
            scanf("%d%d%d",&p[i].w,&p[i].a,&p[i].b);
        for(int i=0; i<n; i++)
        {
            for(int j=p[i].w; j<=m; j++)
                d[j]=max(d[j],d[j-p[i].w]+p[i].a);
            for(int j=m; j>=p[i].w; j--)
                d[j]=max(d[j],d[j-p[i].w]+p[i].a+p[i].b);
        }
        printf("%d\n",d[m]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值