ZOJ - 3939 The Lucky Week (规律)

The Lucky Week

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3939

Edward, the headmaster of the Marjar University, is very busy every day and always forgets the date.

There was one day Edward suddenly found that if Monday was the 1st, 11th or 21st day of that month, he could remember the date clearly in that week. Therefore, he called such week "The Lucky Week".

But now Edward only remembers the date of his first Lucky Week because of the age-related memory loss, and he wants to know the date of the N-th Lucky Week. Can you help him?

Input

There are multiple test cases. The first line of input is an integer T indicating the number of test cases. For each test case:

The only line contains four integers Y, M, D and N (1 ≤ N ≤ 109) indicating the date (Y: year, M: month, D: day) of the Monday of the first Lucky Week and the Edward's query N.

The Monday of the first Lucky Week is between 1st Jan, 1753 and 31st Dec, 9999 (inclusive).

Output

For each case, print the date of the Monday of the N-th Lucky Week.

Sample Input

2
2016 4 11 2
2016 1 11 10

Sample Output

2016 7 11
2017 9 11

 

题目大意: t组数据,每组数据给 你年月日,并且这是一个幸运周,问从这一天起的第k个幸运周的日期,(幸运周:是这一周的星期一,并且是这个月的1 11 或 21日)

思路: 400年是一个轮回,每四百年有2058个幸运周,对于2058以内的直接模拟,每次d+7,判断一下这天是不是1 ,11  或者21

代码:
 

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int mo[15]={0,31,28,31,30,31,30,31,31,30,31,30,31};
int fun(int x)
{
    if(x%4==0&&x%100!=0||x%400==0)
        return 1;
    return 0;
}
int main()
{
    int y,m,d,t,n;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d",&y,&m,&d,&n);
        y+=(n/2058)*400;
        n%=2058;
        while(n)
        {
            if(d==11||d==21||d==1) n--;
            if(n==0) break;
            if(fun(y)) mo[2]=29;
            else mo[2]=28;
            d+=7;
            if(d>mo[m])
            {
                d-=mo[m];
                m++;
            }
            if(m>12)
            {
                m=1;
                y++;
            }
        }
        printf("%d %d %d\n",y,m,d);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值