L2-012 关于堆的判断

该篇文章描述了一个编程问题,涉及如何在最小堆中插入整数并根据给定的命题(如根节点、兄弟关系、父子关系等)验证这些关系是否成立。程序通过C++实现,利用堆数据结构处理插入和查询操作。
摘要由CSDN通过智能技术生成

将一系列给定数字顺序插入一个初始为空的最小堆。随后判断一系列相关命题是否为真。命题分下列几种:

  • x is the rootx是根结点;
  • x and y are siblingsxy是兄弟结点;
  • x is the parent of yxy的父结点;
  • x is a child of yxy的一个子结点。

输入格式:

每组测试第 1 行包含 2 个正整数 n(≤ 1000)和 m(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间 [−10000,10000] 内的 n 个要被插入一个初始为空的最小堆的整数。之后 m 行,每行给出一个命题。题目保证命题中的结点键值都是存在的。

输出格式:

对输入的每个命题,如果其为真,则在一行中输出 T,否则输出 F

输入样例:

5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10

输出样例:

F
T
F
T
#include <iostream>
#include <cstring>
#include <unordered_map>

using namespace std;

int a[10100];
int n, m;
unordered_map<int, int>h;

int main() {
    memset(a, -0x3f, sizeof a);
    cin >> n >> m;
    cin >> a[1];
    for (int i = 2; i <= n; i ++ ) {
        cin >> a[i];
        for (int j = i; a[j] < a[j / 2]; j /= 2) {
            int tmp = a[j];
            a[j] = a[j / 2];
            a[j / 2] = tmp;
        }
    }
    for (int i = 1; i <= n; i ++ ) h[a[i]] = i;

    while (m -- ) {
        int a, b;
        string op;
        cin >> a >> op;
        if (op == "and") {
            cin >> b >> op >> op;
            if (h[a] && h[b] && h[a] >> 1 == h[b] >> 1) puts("T");
            else puts("F");
        } else {
            cin >> op >> op;
            if (op == "root") {
                if (h[a] == 1) puts("T");
                else puts("F");
            }
            else if (op == "parent") {
                cin >> op >> b;
                if (h[a] && h[b] && h[a] == h[b] >> 1) puts("T");
                else puts("F");
            } else {
                cin >> op >> b;
                if (h[a] && h[b] && h[a] >> 1 == h[b]) puts("T");
                else puts("F");
            }
        }
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值