Problem Description
The TV shows such as You Are the One has been very popular. In order to meet the need of boys who are still single, TJUT hold the show itself. The show is hold in the Small hall, so it attract a lot of boys and girls. Now there are n boys enrolling in. At the beginning, the n boys stand in a row and go to the stage one by one. However, the director suddenly knows that very boy has a value of diaosi D, if the boy is k-th one go to the stage, the unhappiness of him will be (k-1)*D, because he has to wait for (k-1) people. Luckily, there is a dark room in the Small hall, so the director can put the boy into the dark room temporarily and let the boys behind his go to stage before him. For the dark room is very narrow, the boy who first get into dark room has to leave last. The director wants to change the order of boys by the dark room, so the summary of unhappiness will be least. Can you help him?
Input
The first line contains a single integer T, the number of test cases. For each case, the first line is n (0 < n <= 100)
The next n line are n integer D1-Dn means the value of diaosi of boys (0 <= Di <= 100)
Output
For each test case, output the least summary of unhappiness .
Sample Input
2
5
1
2
3
4
55
5
4
3
2
2
Sample Output
Case #1: 20
Case #2: 24
区间dp,dp[i][j]是表示i到j内最小的代价,我们可以发现dp[i][j]的状态可以由它的子问题求解而来,并且都是由区间较小的子问题求出。
对于dp[i][j],我们可以枚举i的出现位置,假设i为第k个出场,那i+1~k个元素一定是前k-1个出场的(即使这其中有元素进栈,它出栈也一定会在i之前,所以i+1~k一定是在前k-1个出场的元素),dp[i+1][k]就是这一段的最优值,而从k+1~j就一定在k之后,如果不考虑前面的元素,最优的值即为dp[k+1][j],但是dp[k+1][j]之前会有k个元素,所以这一段的元素都要额外等待k个人,所以代价要加上(sum[j]-sum[k])*(j-k+1),另外这两段并没有计算i的等待代价,所以要再加上(k-i)*a[i].
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include <cmath>
#include<iostream>
#include<algorithm>
#include <vector>
#include <bitset>
#include <stack>
#define maxn 110
#define ll long long
#define MEM(x,num) memset(x,num,sizeof(x))
#define inf 0x3f3f3f3f
#define mod 1000000007
using namespace std;
int dp[maxn][maxn];
int a[maxn];
int sum[maxn];
int main()
{
int t,n,cas=0;
cin>>t;
while(t--)
{
cin>>n;
memset(sum,0,sizeof(sum));
memset(dp,0,sizeof(dp));
for(int i=1; i<=n; i++)
{
cin>>a[i];
sum[i]=sum[i-1]+a[i];
}
for(int len=2; len<=n; len++)
{
for(int i=1; i<=n&&i+len-1<=n; i++)
{
int j=len+i-1;
dp[i][j]=inf;
for(int k=i; k<=j; k++)
dp[i][j]=min(dp[i][j],dp[i+1][k]+dp[k+1][j]+(sum[j]-sum[k])*(k-i+1)+a[i]*(k-i));
}
}
printf("Case #%d: %d\n",++cas,dp[1][n]);
}
return 0;
}