hdu 2476 String painter(区间dp)

Problem Description

There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?

Input

Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.

Output

A single line contains one integer representing the answer.

Sample Input

zzzzzfzzzzz
abcdefedcba
abababababab
cdcdcdcdcdcd

Sample Output

6
7

这道题目我刚开始是怎么想的呢……首先想到的是对b进行区间dp,如果
b[i]和b[k]相等的时候说明这个地方可以不染,dp[i][j]=dp[i][k-1]+dp[k][j]。然后觉得不对还有问题啊……这样的情况是指对于a中的每个字符都要进行染色,但是实际上当b[i]==a[i]时是可以不染的…… 要怎么对这些情况进行辨别……我当时是没有想出来的……
之后看了别人的题解,我们首先设ans[i]来代替dp[1][i](只是为了后面写起了来方便一些),然后我们比较a[i]和b[i],如果相等,说明这个点可以不染色,所以ans[i]=ans[i-1],如果不相等,那我们就要像之前区间dp一样,把它分成任意两个区间的组合,此时应用ans[k]因为在之前的过程中,ans[k]已经更新过,是此时的最小值,而dp[1][k]一定大于等于它。另外dp[k+1][j]中的值没有更新过,但是dp[1][p](k+1<=p<=j)中是已经更新过的,所以最后情况时可以枚举到。

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include <cmath>
#include<iostream>
#include<algorithm>
#include <vector>
#include <bitset>
#include <stack>
#define maxn 110
#define ll long long
#define MEM(x,num) memset(x,num,sizeof(x))
#define inf 0x3f3f3f3f
#define mod 1000000007

using namespace std;

char a[maxn],b[maxn];
int dp[maxn][maxn];
int ans[maxn];

int main()
{
    while(scanf("%s%s",a+1,b+1)!=EOF)
    {
        int n=strlen(a+1);
        memset(dp,0,sizeof(dp));

        for(int i=1; i<=n; i++) dp[i][i]=1;
        for(int len=2; len<=n; len++)
        {
            for(int i=1; i<=n; i++)
            {
                int j=i+len-1;
                dp[i][j]=dp[i+1][j]+1;
                for(int k=i+1; k<=j; k++)
                {
                    if(b[i]==b[k]) dp[i][j]=min(dp[i][j],dp[i+1][k]+dp[k+1][j]);
                }
            }
        }
        for(int i=1; i<=n; i++) ans[i]=dp[1][i];
        for(int i=1; i<=n; i++)
        {
            if(a[i]==b[i]) ans[i]=ans[i-1];
            else
            {
                for(int j=1; j<i; j++)
                    ans[i]=min(ans[i],ans[j]+dp[j+1][i]);
            }
        }
        cout<<ans[n]<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值