HDU 2476 String painter(两次 区间dp)

                                                  String painter



Problem Description
There are two strings A and B with equal length. Both strings are made up of lower case letters. Now you have a powerful string painter. With the help of the painter, you can change a segment of characters of a string to any other character you want. That is, after using the painter, the segment is made up of only one kind of character. Now your task is to change A to B using string painter. What’s the minimum number of operations?
 

Input
Input contains multiple cases. Each case consists of two lines:
The first line contains string A.
The second line contains string B.
The length of both strings will not be greater than 100.
 

Output
A single line contains one integer representing the answer.
 

Sample Input
  
  
zzzzzfzzzzz abcdefedcba abababababab cdcdcdcdcdcd
 

Sample Output
  
  
6 7

题意;从第一个字符串变成第二个字符串最少的步骤,如ddddd   abcba 需要三步:1、aaaaa  2、abbba  3、abcba

思路:首先预处理将一个空串变成第二个字符串需要的最少步骤,状态方程dp(i,j)=min(dp(i,k)+dp(k+1,j)) 表示从i到j的最少步骤,

 然后就是找第一个字符串变成第二个字符串的最少步骤。

AC代码:

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=100+5;
int dp[maxn][maxn];
char a[maxn],b[maxn];
int ans[maxn];
int main(){
	while(scanf("%s%s",a+1,b+1)==2){
		memset(dp,0,sizeof(dp));
		int l=strlen(a+1);
		
		for(int i=1;i<=l;i++)dp[i][i]=1;
		
		for(int len=2;len<=l;len++)  //长度 
		 for(int i=1;i<=l-len+1;i++){  //起点 
		 	int j=i+len-1;   //终点 
		 	if(b[i]==b[j])
		 	 dp[i][j]=dp[i][j-1];
		 	 else dp[i][j]=dp[i][j-1]+1;
		 	for(int k=i;k<j;k++){    //找分割点 
		 		dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]);  
			 }
		 }
		 
		 for(int i=1;i<=l;i++)
		 ans[i]=dp[1][i];
		 
		 for(int i=1;i<=l;i++){
		 	if(a[i]==b[i])
		 	 ans[i]=ans[i-1]; //当时写成=dp[1][i-1],这个错误找了n久!!!(因为如果有对应位置相同,ans[i-1]!=dp[1][i-1]) 
		 	else {
		 		for(int k=1;k<i;k++)
		 		ans[i]=min(ans[i],ans[k]+dp[k+1][i]);
			 }
		 }
		 
		 printf("%d\n",ans[l]);
	}
	return 0;
} 




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

柏油

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值