U - Hat's Fibonacci
A Fibonacci sequence is calculated by adding the previous two members the sequence, with the first two members being both 1.
F(1) = 1, F(2) = 1, F(3) = 1,F(4) = 1, F(n>4) = F(n - 1) + F(n-2) + F(n-3) + F(n-4)
Your task is to take a number as input, and print that Fibonacci number.
Input
Each line will contain an integers. Process to end of file.
Output
For each case, output the result in a line.
Sample Input
100
Sample Output
4203968145672990846840663646 Note: No generated Fibonacci number in excess of 2005 digits will be in the test data, ie. F(20) = 66526 has 5 digits.
#include<cstdio>
#include<stack>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
#include<iostream>
#include<cmath>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N=7044;
const int mmax=555;
const int MOD = 1e5+ 7;
int num[N][mmax];//数组保留对应位上的数字
int main()
{
memset(num,0,sizeof(num));
int mod=0;
num[1][0]=num[2][0]=num[3][0]=num[4][0]=1;
for(int i=5; i<=7040; i++) //n的最大值可以说出来的,大概在7038之内
{
for(int j=0; j<500; j++)
{
mod+=num[i-1][j]+num[i-2][j]+num[i-3][j]+num[i-4][j];
num[i][j]=mod%100000;
mod/=100000;
}
}
int n;
while(scanf("%d",&n)!=EOF)
{
if(n<5)
{
printf("1\n");
continue;
}
int k=500;
while(!num[n][k])k--;
printf("%d",num[n][k--]);
for(int i=k; i>=0; i--)
printf("%05d",num[n][i]);
printf("\n");
}
return 0;
}