B - Calendar POJ - 2080 (历法)

B - Calendar

 POJ - 2080 

A calendar is a system for measuring time, from hours and minutes, to months and days, and finally to years and centuries. The terms of hour, day, month, year and century are all units of time measurements of a calender system. 
According to the Gregorian calendar, which is the civil calendar in use today, years evenly divisible by 4 are leap years, with the exception of centurial years that are not evenly divisible by 400. Therefore, the years 1700, 1800, 1900 and 2100 are not leap years, but 1600, 2000, and 2400 are leap years. 
Given the number of days that have elapsed since January 1, 2000 A.D, your mission is to find the date and the day of the week.

Input

The input consists of lines each containing a positive integer, which is the number of days that have elapsed since January 1, 2000 A.D. The last line contains an integer −1, which should not be processed. 
You may assume that the resulting date won’t be after the year 9999.

Output

For each test case, output one line containing the date and the day of the week in the format of "YYYY-MM-DD DayOfWeek", where "DayOfWeek" must be one of "Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" and "Saturday".

Sample Input

1730
1740
1750
1751
-1

Sample Output

2004-09-26 Sunday
2004-10-06 Wednesday
2004-10-16 Saturday
2004-10-17 Sunday

给定一个正整数n,求从January 1, 2000 公元,开始经过n天的具体年份,月份,日,和星期数,例如n=1,时,输出

2000-01-02 Sunday.

 

#include<cstdio>
#include<stack>
#include<set>
#include<vector>
#include<queue>
#include<algorithm>
#include<cstring>
#include<string>
#include<map>
#include<iostream>
#include<cmath>
using namespace std;
#define inf 0x3f3f3f3f
typedef long long ll;
const int N=110;
const int nmax = 60200;
const double esp = 1e-9;
const double PI=3.1415926;
char a[7][13]={"Saturday","Sunday", "Monday", "Tuesday", "Wednesday", "Thursday", "Friday" };
int judge(int y){
if((y%4==0&&y%100!=0)||y%400==0)
      return 366;
return 365;
}
int num_month(int ans,int mon){
if(mon==2){
      return ans==366?29:28;
}
if(mon==2||mon==4||mon==6||mon==9||mon==11)
      return 30;
return 31;
}
int main()
{
    int n,y,m,w;
    while(scanf("%d",&n)!=EOF){
      if(n==-1)
            break;
      int sum=0,ans;
      w=n%7;
      for(int i=2000;i<10000;i++){
            ans=judge(i);
            if(sum+ans<=n){
                  sum+=ans;
                  continue;
            }
            else{
                 y=i;
                 n-=sum-1;  //此时的n为该年的第n天
                 m=1;
                 int num=num_month(ans,m);
                 while(n>num){
                  n-=num;
                  m++;
                  num=num_month(ans,m);
                 }
                 break;
            }
      }
      printf("%d-%02d-%02d %s\n",y,m,n,a[w]);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值