2014ACM集训13级PK赛3-Friends

Description

Alice lives in the country where people like to make friends. The friendship is bidirectional and if any two person have no less than kfriends in common, they will become friends in several days. Currently, there are totally n people in the country, and m friendship among them. Assume that any new friendship is made only when they have sufficient friends in common mentioned above, you are to tell how many new friendship are made after a sufficiently long time.

Input

There are multiple test cases.

The first lien of the input contains an integer T (about 100) indicating the number of test cases. Then T cases follow. For each case, the first line contains three integers n, m, k (1 ≤ n ≤ 100, 0 ≤ m ≤ n×(n-1)/2, 0 ≤ k ≤ n, there will be no duplicated friendship) followed by mlines showing the current friendship. The ith friendship contains two integers ui, vi (0 ≤ ui, vi < nui ≠ vi) indicating there is friendship between person ui and vi.

Note: The edges in test data are generated randomly.

Output

For each case, print one line containing the answer.

Sample Input

3
4 4 2
0 1
0 2
1 3
2 3
5 5 2
0 1
1 2
2 3
3 4
4 0
5 6 2
0 1
1 2
2 3
3 4
4 0
2 0

Sample Output

204

 

 

不科学的题目= =,这次比赛看似不可能的题目都暴力过了,真是渣数据

#include <stdio.h>
#include <string.h>
#include <stdlib.h>

int p[101][101];

int main()
{
    int N;
    scanf ("%d",&N);
    while (N--)
    {
        memset (p,0,sizeof(p));
        int n,m,K;
        int i,k;

        scanf ("%d%d%d",&n,&m,&K);

        for (i = 0; i < m; i++)
        {
            int a,b;
            scanf ("%d%d",&a,&b);
            p[a][b] = 1;
            p[b][a] = 1;
        }
        int ans = 0;
        int tf = 1;

        while (tf)
        {
            tf = 0;
            for (i = 0; i < n; i++)
            {
                for (k = i + 1; k < n; k++)
                {
                    if (p[i][k])
                        continue;

                    int sum = 0;
                    for (int j = 0; j < n; j++)
                    {
                        if (p[i][j] == 1 && p[k][j] == 1)
                            sum++;
                    }
                    if (sum >= K)
                    {
                        tf = 1;
                        ans++;
                        p[i][k] = 1;
                        p[k][i] = 1;
                    }
                }
            }
        }

        printf ("%d\n",ans);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值