Fermat vs. Pythagoras POJ - 1305(本原勾股数组)

Fermat vs. Pythagoras

POJ - 1305
Computer generated and assisted proofs and verification occupy a small niche in the realm of Computer Science. The first proof of the four-color problem was completed with the assistance of a computer program and current efforts in verification have succeeded in verifying the translation of high-level code down to the chip level.
This problem deals with computing quantities relating to part of Fermat's Last Theorem: that there are no integer solutions of a^n + b^n = c^n for n > 2.
Given a positive integer N, you are to write a program that computes two quantities regarding the solution of x^2 + y^2 = z^2, where x, y, and z are constrained to be positive integers less than or equal to N. You are to compute the number of triples (x,y,z) such that x < y < z, and they are relatively prime, i.e., have no common divisor larger than 1. You are also to compute the number of values 0 < p <= N such that p is not part of any triple (not just relatively prime triples).
Input
The input consists of a sequence of positive integers, one per line. Each integer in the input file will be less than or equal to 1,000,000. Input is terminated by end-of-file
Output
For each integer N in the input file print two integers separated by a space. The first integer is the number of relatively prime triples (such that each component of the triple is <=N). The second number is the number of positive integers <=N that are not part of any triple whose components are all <=N. There should be one output line for each input line.
Sample Input
10
25
100
Sample Output
1 4
4 9
16 27
分析:直接套用公式
(a,b,c)为本原勾股数组a = s*t , b = (s*s - t*t)/2  ,  c = (s*s + t*t)/2.其中 s > t >= 1,s,t是没有公因数的奇数。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int gcd(int a,int b){
    if(b == 0) return a;

    return gcd(b,a%b);
}
int vis[1000010];
int main(){
    int s,t;
    int n;
    while(~scanf("%d",&n)){
        memset(vis,0,sizeof(vis));
        int cnt = 0;
        for(s = 1; s <= n; s++){
            for(t = 1; t < s; t++){
                int a,b,c;
                if(s%2 == 1 && t%2 == 1 && gcd(s,t) == 1){//利用本原勾股数组公式求出本原勾股数组
                    a = s*t;
                    b = (s*s-t*t)/2;
                    c = (s*s+t*t)/2;
                    if(c <= n){//判定范围,如果在n之内,个数加一
                        cnt++;
                        int k;
                        for(k = 1; k*c <= n; k++){//将包括这和个数组在内的它的倍数标记
                            vis[a*k] = 1;
                            vis[b*k] = 1;
                            vis[c*k] = 1;
                        }
                    }
                }
            }
        }
        int i,v = 0;
        for(i = 1; i <= n; i++){//遍历计算出剩下的没用过的数
            if(vis[i]==0)v++;
        }
        printf("%d %d\n",cnt,v);//输出
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值