Find Small A HDU - 5980(移位取模水题)

Find Small A HDU - 5980

 As is known to all,the ASCII of character 'a' is 97. Now,find out how many character 'a' in a group of given numbers. Please note that the numbers here are given by 32 bits’ integers in the computer.That means,1digit represents 4 characters(one character is represented by 8 bits’ binary digits). 

Input
The input contains a set of test data.The first number is one positive integer N (1≤N≤100),and then N positive integersai (1≤ ai
≤2^32 - 1) follow
Output
Output one line,including an integer representing the number of ‘a’ in the group of given numbers.
Sample Input

3
97 24929 100

Sample Output

3

每次取模1<<8然后每次向左移八位

code:

#include <iostream>
#include <cstdio>
using namespace std;
int main(){
    int n,ans = 0;
    scanf("%d",&n);
    for(int i = 0; i < n; i++){
        int x;
        scanf("%d",&x);
        while(x){
            if(x % (1<<8) == 97) ans++;
            x >>= 8;
        }
    }
    printf("%d\n",ans);
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值