HDU 2824 The Euler function (欧拉函数水题)

The Euler function

 The Euler function phi is an important kind of function in number theory, (n) represents the amount of the numbers which are smaller than n and coprime to n, and this function has a lot of beautiful characteristics. Here comes a very easy question: suppose you are given a, b, try to calculate (a)+ (a+1)+....+ (b) 

Input
There are several test cases. Each line has two integers a, b(2 < a < b < 3000000)
Output
Output the result of (a)+ (a+1)+….+ (b)
Sample Input

3 100

Sample Output

3042

裸的欧拉函数题

一开始想预处理处前缀和直接输出,结果内存超了,然后一个一个暴力加起来就过了。。

code:

#include <bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn = 3000010;
int phi[maxn];
void Euler(){
    phi[1] = 1;
    for(int i = 2; i < maxn; i++){
        phi[i] = i;
    }
    for(int i = 2; i < maxn; i++){
        if(phi[i] == i){
            for(int j = i; j < maxn; j += i){
                phi[j] = phi[j] / i * (i - 1);
            }
        }
    }
}
int main(){
    Euler();
    int a,b;
    while(scanf("%d%d",&a,&b)!= EOF){
        ll ans = 0;
        for(int i = a; i <= b; i++){
            ans += (ll)phi[i];
        }
        printf("%lld\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值