uva 10041 Vito's Family

38 篇文章 0 订阅
9 篇文章 0 订阅

The world-known gangster Vito Deadstone is moving to New York. He has a very big family there, all of them living in Lamafia Avenue. Since he will visit all his relatives very often, he is trying to find a house close to them.
Vito wants to minimize the total distance to all of them and has blackmailed you to write a program that solves his problem.

Input
The input consists of several test cases. The first line contains the number of test cases.
For each test case you will be given the integer number of relatives r (0 < r < 500) and the street numbers (also integers) s1, s2, … , si, … , sr where they live (0 < si < 30000 ). Note that several
relatives could live in the same street number.

Output
For each test case your program must write the minimal sum of distances from the optimal Vito’s house to each one of his relatives. The distance between two street numbers si and sj is dij = |si − sj |.

Sample Input
2
2 2 4
3 2 4 6

Sample Output
2
4

题意:
给定一组整数,找出其中一个数n,使得该数与其他数的差的绝对值之和s最小,输出s(即求中位数与数组中其他数的差的绝对值之和)
代码:

#include <iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
    int n,i,m,k,d;
    int num[500];
    cin>>n;
    while(n>0)
    {
        cin>>m;
        d=0;
        for(i=0;i<m;i++)
        {
            cin>>num[i];
        }
        sort(num,num+m);//排序,默认为升序
        k=m/2;//得到中位数的下标
        for(i=0;i<m;i++)
        {
            d+=abs(num[i]-num[k]);
        }
        cout<<d<<endl;
        n--;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值