POJ 1284 Primitive Roots 原根(欧拉函数)


Primitive Roots
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2637 Accepted: 1486

Description

We say that integer x, 0 < x < p, is a primitive root modulo odd prime p if and only if the set { (x i mod p) | 1 <= i <= p-1 } is equal to { 1, ..., p-1 }. For example, the consecutive powers of 3 modulo 7 are 3, 2, 6, 4, 5, 1, and thus 3 is a primitive root modulo 7. 
Write a program which given any odd prime 3 <= p < 65536 outputs the number of primitive roots modulo p. 

Input

Each line of the input contains an odd prime numbers p. Input is terminated by the end-of-file seperator.

Output

For each p, print a single number that gives the number of primitive roots in a single line.

Sample Input

23
31
79

Sample Output

10
8
24

Source


给你一个奇素数,让你求它原根的个数。

m是正整数,a是整数,若a模m的阶等于φ(m),则称a为模m的一个原根。(其中φ(m)表示m的欧拉函数)

假设一个数g对于P来说是原根,那么g^i mod P的结果两两不同,且有 1<g<P, 0<i<P,那么g可以称为是P的一个原根,归根到底就是g^(P-1) = 1 (mod P)当且当指数为P-1的时候成立.(这里P是素数).

简单来说,g^i mod p ≠ g^j mod p (p为素数)

其中i≠j且i, j介於1至(p-1)之间

则g为p的原根。

【算法】定理1:如果p有原根,则它恰有φ(φ(p))个不同的原根(无论p是否为素数都适用) 
   {x^i%p | 1 <= i <= p - 1} = {1,2,...,p-1} 等价于 
   {x^i%(p-1) | 1 <= i <= p - 1} = {0,1,2,...,p-2},
   即为(p-1)的完全剩余系若x,x2...x(p-1)是(p-1)的完全剩余系,根据定理,可以推出若
   gcd(x, p-1) = 1时, (1,x,...,x(p-2))也是(p-1)的完全剩余系
   因为若x^i != x^j (mod p-1),那么x*x^i != x*x^j (mod p-1),
   与条件m矛盾,所以 x^i = x^j (mod p-1),
   由此可以确定答案为Euler(p-1)
//388K	16MS
#include<stdio.h>
int eular(int n){
       int ret=1,i;
       for (i=2;i*i<=n;i++)
              if (n%i==0){
                     n/=i,ret*=i-1;
                     while (n%i==0)
                            n/=i,ret*=i;
              }
       if (n>1)
              ret*=n-1;
       return ret;
}
int main()
{
    int c,n;
    while(scanf("%d",&n)!=EOF)
    {
        printf("%d\n",eular(n-1));
    }
    return 0;
}


  



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值