POJ 3264 Balanced Lineup 线段树求区间最大最小(普通线段树,ZKW线段树)

Balanced Lineup
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 30604 Accepted: 14431
Case Time Limit: 2000MS

Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ ABN), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

 

【题目大意】:

         给出一串的数字,然后给出一个区间a b,输出从a到b的最大的数和最小的数的差

【分析】:

         用线段树,代码给出两种线段树:普通线段树和ZKW线段树

【代码1,普通线段树】:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<vector>
#include<stack>
#include<queue>
using namespace std;
#define MAX 50001
#define MAXP 250001
#define IMAX 214748364
int N,Q,a[MAX],value[MAXP],min1[MAXP],max1[MAXP],ans1,ans2;
void build(int node,int left,int right)
{
      if(left==right)
      {
            min1[node]=a[left];
            max1[node]=a[left];
      }
      else
      {
            int middle=(left+right)/2;
            build(2*node,left,middle);
            build(2*node+1,middle+1,right);
            min1[node]=min(min1[2*node],min1[2*node+1]);
            max1[node]=max(max1[2*node],max1[2*node+1]);
      }
}
void find(int node,int left,int right,int L,int R)
{
      if(L<=left && right<=R)
      {
            //printf("node:%d\n",node);
            ans1=min(min1[node],ans1);
            ans2=max(max1[node],ans2);
      }
      else
      {
            int middle=(left+right)/2;
            if(L<=middle)   
                  find(2*node,left,middle,L,R);
            if(R>middle)
                  find(2*node+1,middle+1,right,L,R);
      } 
      //maintain(node,left,right);
}
int main()
{
      //freopen("input.in","r",stdin);
	  //freopen("output.out","w",stdout); 
	  scanf("%d%d",&N,&Q);
	  for(int i=1;i<=N;i++)
	        scanf("%d",&a[i]);
      build(1,1,N);
      /*for(int i=1;i<=4*N;i++)
            printf("min[%d]=%d\n max[%d]=%d\n",i,min1[i],i,max1[i]);*/
      for(int i=1;i<=Q;i++)
      {
            int A,B;
            ans1=IMAX;
            ans2=-1;
            scanf("%d%d",&A,&B);
            find(1,1,N,A,B);
            //printf("%d %d\n",ans1,ans2);
            printf("%d\n",ans2-ans1);
      }
	  //system("pause");
      return 0;
}


 

【代码2,ZKW线段树】:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<vector>
#include<stack>
#include<queue>
using namespace std;
#define IMAX 21474836
#define MAX 50001
int N,Q,M,min1[4*MAX],max1[4*MAX];
int getmax(int left,int right)
{
      int ansnow=-1;
      for(left+=M-1,right+=M+1;left^right^1;left/=2,right/=2)
      {
            if(~left&1)   ansnow=max(ansnow,max1[left^1]);
            if(right&1)   ansnow=max(ansnow,max1[right^1]);
      }
      return ansnow;
}
int getmin(int left,int right)
{
      int ansnow=IMAX;
      for(left+=M-1,right+=M+1;left^right^1;left/=2,right/=2)
      {
            if(~left&1)   ansnow=min(ansnow,min1[left^1]);
            if(right&1)   ansnow=min(ansnow,min1[right^1]);
      }
      return ansnow;
}
int main()
{
      //freopen("input.in","r",stdin);
	  //freopen("output.out","w",stdout); 
	  scanf("%d%d",&N,&Q);
	  for(M=1;M<=N+1;M*=2);
	  for(int i=1;i<=N;i++)
	  {
            scanf("%d",&min1[i]);
            min1[i+M]=max1[i]=max1[i+M]=min1[i];
      }
      for(int i=M;i>=1;i--)
      {
            min1[i]=min(min1[2*i],min1[2*i+1]);
            max1[i]=max(max1[2*i],max1[2*i+1]);
      }
      for(int i=1;i<=Q;i++)
      {
            int A,B;
            scanf("%d%d",&A,&B);
            printf("%d\n",getmax(A,B)-getmin(A,B));
      }
	  //system("pause");
      return 0;
}


 

转载注明出处: http://blog.csdn.net/u011400953

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值